9

I am having an error when publishing Sitecore profiles on a test environment. I created the profile Test with profile keys Key1 and Key2.

Profile card and pattern cards were created also. See screenshot below.

Screenshot of Pattern/Profile Cards created

I tagged content (an article page) with the profile card Tag1.

Everything appears good on the master database.

Screenshot of Profile Cards

After publishing the profile and the content, I accessed the article page (more than 3 times) on the website for the user to get assigned a pattern card.

When checking the interaction of the user using:

Tracker.Current.Session.Interaction.Profiles["Test"]

There is no profile Test assigned to the current user.

So I went to check the web database if everything has been published correctly. My article was no longer tagged with the profile card.

enter image description here

The profile cards and pattern cards are present in Marketing Control Panel but the radar chart is not populated with anything but the raw values contains the value that were set in the master db.

enter image description here

enter image description here

I tried to delete the Profiles container in the web db and re publish everything. There were some profiles that were created earlier and were working. Now these too are not working.

I tried to clean up the database, rebuild link database and even deploy marketing definition from control panel. Still no luck.

2

Sitecore Publishing Service was being used to handle all publishing on the environment. I do not know if the issue was from this or not but when I tried to transfer Profile item with sub items to the web database, it seems to have fixed the issue.

  • Interesting is SPS is the issue. That is certainly a bug if true. – Chris Auer Aug 21 '17 at 23:16
  • 1
    I just encountered the same issue with Sitecore 8.2.4. Removing the items and publishing through the old api seemed to correct the behavior. – Michael West May 10 '18 at 20:00
  • I can third this (even after switching back to standard publishing I had to remove the items from the web db and publish again), has anyone had confirmation of the issue from support? – Nick Allen Nov 20 '18 at 17:01
  • Same here on 9.0.2. Remove items and classic publish solved the problem. – Mark Lowe Oct 30 at 14:06
0

When you create any new profile, it will have default workflow assigned to it. You can enable the Gutter to check whether item is under workflow or not. If it is under workflow then it will show you small icon as shown in below screen. Now, you need clear the stages of workflow till final stage and then only you will be able to publish it.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.