5

Some how, the local "Data" folder (the one from SXA), underneath a page, is not displayed for content editors in the Content Editor:

Screenshot from content editors perspective

While an admin is able to see it in the Content Editor: Screenshot from admin perspective

According to the access viewer the content editor should be able to see it: enter image description here

Is this a "feature" of the SXA local "Data" folder, to prevent users from editing it in the content editor because they should use the Experience Editor?

  • 2
    is Data folder marked as hidden? Can you check for the other users in the "view" ribbon tab, if "show hidden items" is checked? – Marek Musielak Aug 25 '17 at 11:14
  • Agreed. The Data folder is likely hidden, this would be best practice. – Mark Cassidy Aug 25 '17 at 11:25
  • Thanks @MarekMusielak! The folder was hidden indeed. And although it could be best practice, I disabled the "hidden" checkbox on the standard values item for the Data template for now. – Arjen van Veen Aug 28 '17 at 9:41
  • @ArjenvanVeen I'm glad I helped. Comment converted into an answer. – Marek Musielak Aug 28 '17 at 10:39
7

The local Data folder in SXA is usually hidden.

Check for the other users in the View ribbon tab, if Hidden items checkbox is checked:

enter image description here

| improve this answer | |
0

While trying to configure security for the users of our system, I found that I needed to grant access to the template used for the Data item; which I believe is a Virtual Page Data.

Example: The following applies security changes to the Data folders.

# This is a helper method to simplify the changes.
function New-AccessRuleList {
    [CmdletBinding()]
    [OutputType("System.Collections.Generic.List[Sitecore.Security.AccessControl.AccessRule]")]
    param(
        [string]$Identity,
        [string[]]$AccessRule,
        [Sitecore.Security.AccessControl.PropagationType]$PropagationType,
        [Sitecore.Security.AccessControl.SecurityPermission]$SecurityPermission
    )

    $list = New-Object "System.Collections.Generic.List[Sitecore.Security.AccessControl.AccessRule]"
    foreach($rule in $accessrule) {
        $list.Add((New-ItemAcl -Identity $Identity -AccessRight $rule -PropagationType $PropagationType -SecurityPermission $SecurityPermission))
    }

    @(,$list)
}

$allowItemProps = @{
    PropagationType = [Sitecore.Security.AccessControl.PropagationType]::Entity
    SecurityPermission = [Sitecore.Security.AccessControl.SecurityPermission]::AllowAccess
}

$realEveryone = "\Everyone"
$virtualDataItem = Get-Item -Path "master:" -ID "{9700DC24-8969-4638-ACC3-34D54335829E}"
$accessRules = New-Object Sitecore.Security.AccessControl.AccessRuleCollection
$accessRules.AddRange((New-AccessRuleList -Identity $realEveryone -AccessRule item:create @allowItemProps))
$virtualDataItem | Add-ItemAcl -AccessRules $accessRules

The final results:

Security Settings On Item

| improve this answer | |
  • Thanks for your reply @Michael, but it had nothing to do with access rights. The item was just hidden because the "hidden" checkbox was checked in the standard values item for the Data template. – Arjen van Veen Aug 28 '17 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.