3

I am trying to setup my Sitecore project in my new laptop with Windows 10 using Sitecore Instance Manager (SIM). I am also using their Solr add-on option. Everything is marked as "DONE" in the SIM setup.

However, when I am trying to access my sitecore/login page it is just loading forever. I have provided necessary "Full Control" permissions to IUSR, NETWORK SERVICE and IIS_IUSRS accounts for the deploy folder. And of-course to the App pool instance.

Let me know where I missed the things

-EDIT-

Here is my log, which is showing some error related to Analytics, but I am sure this shouldn't be a problem or is it ?

10860 14:15:21 ERROR Exception when executing agent aggregation/automationAggreg ator Exception: System.NullReferenceException Message: Object reference not set to an instance of an object. Source: Sitecore.Analytics.MongoDB at Sitecore.Analytics.RangeScheduler.MongoDbRangeMap2.TryLockRange(WorkerHand le worker, DateTime leaseExpiration, RangeHandle& range) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler21.TryLockRan ge(WorkScheduler1& context) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler21.GetNextRan ge(WorkScheduler1& context) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler2`1.TryGetNext (TKey& item) at Sitecore.Analytics.Automation.Aggregation.AutomationWorkDispatcher.TryGetN ext(AutomationWorkItem& workItem) at Sitecore.Analytics.Automation.Aggregation.Data.Processing.AggregatorAgent. Execute() at Sitecore.Analytics.Core.BackgroundService.Run()

8232 14:15:22 ERROR Exception when executing agent aggregation/automationAggrega tor Exception: System.NullReferenceException Message: Object reference not set to an instance of an object. Source: Sitecore.Analytics.MongoDB at Sitecore.Analytics.RangeScheduler.MongoDbRangeMap2.TryLockRange(WorkerHand le worker, DateTime leaseExpiration, RangeHandle& range) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler21.TryLockRan ge(WorkScheduler1& context) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler21.GetNextRan ge(WorkScheduler1& context) at Sitecore.Analytics.Core.RangeScheduler.RangeMapWorkScheduler2`1.TryGetNext (TKey& item) at Sitecore.Analytics.Automation.Aggregation.AutomationWorkDispatcher.TryGetN ext(AutomationWorkItem& workItem) at Sitecore.Analytics.Automation.Aggregation.Data.Processing.AggregatorAgent. Execute() at Sitecore.Analytics.Core.BackgroundService.Run()

  • 1
    Post your log, please. – Mark Cassidy Sep 9 '17 at 8:32
  • Make sure mongoDB service is running. If you don't have mongoDB, just disable the analytics and see if the page still takes time to load – Hishaam Namooya Sep 9 '17 at 12:25
  • @HishaamNamooya Thank you. This worked. But I was not sure this could be the reason. I have saw my previous applications worked without MongoDb in place. Thanks anyways. Can you please have this comment as answer so I can mark it ? – Seenu Kuppan Sep 9 '17 at 14:32
  • @SeenuKuppan I have added the answer – Hishaam Namooya Sep 9 '17 at 14:40
  • For me, Restarting MongoDB service did not worked. Please try restart IIS Server and Mongo Service both. – Pankaj Sharma Jun 14 at 5:37
3

The issue is related to connection to the MongoDB database. You need to make sure that the MongoDB service is on.

If ever you do not intend to use MongoDB, you need to disable the Sitecore Analytics in the config file from the Include folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.