1

Suddenly the button for Edit is not displayed anymore and I can't edit the layout, I can edit the fields for the item but I need to edit the layout to actually see something, any ideas of what is causing this? I've been looking at different things for days now.

This is how it looks

Edit: I think I figured it out, it may not have to do anything with permissions, it seems that the db was corrupted and the base templates lost their base fields (__Base template) and so a lot of stuff is broken, I've been trying to fix them but it seems to be a bit more complicated than I first thought and I may need to restore the database. I'll leave the question open until I confirm this is indeed the issue.

Final Edit: I managed to fix the database and that was indeed the main issue, once the base templates had the proper fields and values everything was back to normal (I still need to fix some stuff but main functionality is ok).

  • Can you share a screen snippet of where you expect it to be? Also, what type of user account you're logged in as (assuming you know) – Mark Cassidy Sep 11 '17 at 22:47
  • This is how home and presentation look right now, this is logged in as admin, in access viewer everything is green for that item and items under it. imgur.com/a/h9n3K – Gamaliel Sep 11 '17 at 23:33
  • As an admin, you shouldn't need to lock an item in order to edit it – Zachary Kniebel Sep 12 '17 at 11:43
2

It looks like you are not logged in as a Sitecore admin (where the user account have the "Administrator" checkbox checked). if you were, you would see more buttons/commands both in the home tab and in the Presentation tab. When logging in with an account that has the "Administrator" checkbox checked, all security is disregarded and you have access to everything. You need to check your current users access rights to applications, tabs, and commands in the core database for access to specific tabs, buttons, etc.

An admin could also have accidentally moved or deleted buttons or tabs in the core database. if you have access rights, please check if the missing buttons are actually there in the core database. If not, check if you can restore them from the recycle bin

| improve this answer | |
  • You're right, I'm a member of local administrator but not actually admin, do I need write access to applications, tabs and commands or read is enough? i.imgur.com/UA5jcY6.png – Gamaliel Sep 12 '17 at 14:15
  • Got an actual admin user to check and same thing, I see the commands in other items (while I was checking core db) but I can't see them while on master (or web) db. – Gamaliel Sep 12 '17 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.