1

I have fresh installation of sitecore and have just added only one content into sitecore content tree. Whenever I click on presentation tab and try to preview "mypage" content "Tracker.Current is not initialized" error is displayed. But my home page preview is working fine. What is the issue here. Sitecore 8.2 is used.

enter image description here

4
  • check if your session state is disabled, the tracker cannot work without it.
    – alexp83
    Sep 14 '17 at 1:14
  • Session state is enabled and preview did work for home item but not for 'mypage' item. (pl refer above pic) <sessionState mode="InProc" cookieless="false" timeout="20" sessionIDManagerType="Sitecore.SessionManagement.ConditionalSessionIdManager">
    – Umar D
    Sep 14 '17 at 1:44
  • @UmarD: What is the Sitecore version and Environment details?. Can you check mongo service is up and running? here are the possible reasons for these issues broair.wordpress.com/2016/10/28/… Sep 14 '17 at 4:00
  • First thing to check is if mongo is running. If there is a custom component on the page that use Tracker, make sure you initialize it first. if (Tracker.Current == null) { Tracker.Initialize(); }
    – adarsh
    Sep 14 '17 at 6:43
2

When I've seen this issue before it's often been caused by Sitecore being unable to access MongoDB to store analytics data. (As mentioned in the comments above)

That may be because:

  • The connection strings for access to Analytics data in MongoDB are not correct.
  • The MongoDB service that the connection strings point to is not running.
  • Some sort of firewall or networking issue is blocking connectivity between the Sitecore server and the MongoDB server.

Since you say it's a "fresh install" my guess is that the connection strings aren't correct. They're probably still the default values. So you should check the contents of the ConnectionStrings.xml file in the Website\App_Config folder, and make sure the connection settings for the analytics data are right for your MongoDB instance.

The Sitecore installer doesn't set up a MongoDB service - you either have to install MongoDB yourself or you can get access to a hosted instance if you prefer.

Or, if you don't want to run MongoDB and don't need the analytics-based features in Sitecore you can turn it off by adjusting the configuration of Sitecore to disable xDB.

2

Not the answer you're looking for? Browse other questions tagged or ask your own question.