5

enter image description here

The only thing that works for me, is the line commented out in the screenshot below:

Comment the InsertLinkViaTreeDialog

enter image description here

I Tried lots of solutions provided in the community but didn't work for me except the one below:

https://community.sitecore.net/developers/f/8/t/863

https://jammykam.wordpress.com/2015/08/26/general-link-field-bug-with-internal-links-opening-in-new-window/

https://blog.horizontalintegration.com/2015/06/20/sitecore-8-general-link-field-internal-link-target-doesnt-render-properly/

http://www.bugdebugzone.com/2015/06/sitecore-8-general-link-field-target_23.html

Any Clue? Which direction should we move with?

  • is it a RTE field or a General Link ? – Vlad Iobagiu Sep 14 '17 at 10:05
  • This is general link – Ashish Bansal Sep 14 '17 at 11:54
3

Add the Versions for the below childs of Targets /sitecore/client/Applications/Dialogs/InsertLinkViaTreeDialog/PageSettings/Targets

Then check the Internal Link, you will see 2 entries in Target dropdown.

After that remove the latest version and again check the Internal Link. You can see those Targets dropdown values

| improve this answer | |
  • 4
    Siva Kumar's answer is correct, but it doesn't explain why it works. In reality, you have to reindex the Core database, and when you create and delete a version from an item, that item is reindexed. Try reindexing your core database and see if it works, it did for me. – Cristian Delgado May 15 '18 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.