3

Using Sitecore 8.1 update 3 for our multilingual web application. Here all the items (using the same template, ex : Product template) are rendered as empty/blank page with no error message and don't find any error in logs also.

our url stategy is like this : xyz.com --> en sg.xyz.com --> en-sg It is working fine for all countries except one.

I have verified the below things: All these pages are working fine in Preview. The items are present in web db. The items are available in solr indexes.

Any leads on this issue will be helpful.

3
  • What is the Sitecore path to your home item? Give the following a try: navigate to http://xyz.com/sitecore/content/path/to/home (replacing path/to/home with the path to your home item) and share the results Sep 14 '17 at 12:47
  • Home item path : /sitecore/content/MasterSG/Home
    – Dheeraj p
    Sep 14 '17 at 12:52
  • Yup, so try the suggestion in my answer by navigating to http://xyz.com/sitecore/contet/MasterSG/Home. If the page loads and is not blank then you have confirmed the issue, as described in my post Sep 14 '17 at 12:58
2

I most commonly see the issue that you are describing when there is something wrong with the site definitions - the <site name="website"...> nodes - in the Sitecore configuration.This happens because Sitecore is not resolving the sites correctly. The reason why the pages work in Preview is because Sitecore resolves the item via its ID, which is directly passed in the Query String when in Preview mode.

The first thing that I would do is try to navigate to the your Sitecore item directly in the browser, while in normal browsing mode. You do this as follows:

  1. Log into Sitecore and navigate to your home item in the Content Editor
  2. Copy the item path of your home item from the "Quick Info" section
  3. Open up a new browser tab and navigate to http://xyz.com/<sitecore_path_here>. This should look something like http://xyz.com/sitecore/content/mysite/home. Note that you can use any host for the site that is configured in IIS to point at your application. By using the Sitecore path to request your item, you are bypassing all site-resolving logic in Sitecore, so the host you use shouldn't matter so long as it points at the right application.

    UPDATE: Based on your comments, the path to your home node is /sitecore/contet/MasterSG/Home so you should be doing this test by navigating to http://xyz.com/sitecore/contet/MasterSG/Home.

  4. If your page loads, then you have confirmed that your issue is occurring when Sitecore tries to resolve your sites

If your page loads after running the above test, update your post with your site definitions configuration and we can troubleshoot further.

-1

I ran into same situation.. and thought of posting how I fixed it, may help someone..

In my case datasource paths on the renderings were pointing to old location where I moved them from. After correcting those paths my pages started working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.