0

Im using Sitecore 8.2 project with Unicorn for item syncronization. When I run the Gulp task, Im getting the following error.

Missing value for Unicorn config node 'targetDataStore', 'type' attribute (type expected).
  • Share relevant configuration snippets, please. Specifically those that deal with Unicorn setup. – Mark Cassidy Sep 14 '17 at 20:07
  • Did you get the chance to fix this? I am also having the same issue. – Marvin Glenn Lacuna Jan 24 '18 at 8:53
1

This line is in the Unicorn.config:

<targetDataStore physicalRootPath="$(dataFolder)\Unicorn\$(configurationName)" useDataCache="false" type="Rainbow.Storage.SerializationFileSystemDataStore, Rainbow" singleInstance="true"/>

Seems as though you may be missing this attribute: type="Rainbow.Storage.SerializationFileSystemDataStore, Rainbow"

Take a look at your Unicorn.config OR you may be using a patch file, and it would be wise to run a search through the solution for "targetDataStore" and see if the type is missing in the patch file.

  • This solution did not work for me as the target was already present . <targetDataStore physicalRootPath="$(dataFolder)\Unicorn\$(configurationName)" useDataCache="false" type="Rainbow.Storage.SerializationFileSystemDataStore, Rainbow" singleInstance="true"/> – Mike Nov 1 '17 at 16:39
0

I found the solution. In my case, I am using Sitecore v9 with SXA and deploying the Sitecore XA Showcase project of Cognfide (https://github.com/Cognifide/Sitecore.XA.Showcase) to my local machine.

It problem was because of the wrong versions of the following assemblies:

enter image description here

Hence, ensure that your packages.config looks like this:

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="Kamsar.WebConsole" version="2.0.0.0" targetFramework="net46" />
  <package id="MicroCHAP" version="1.2.2.2" targetFramework="net46" />
  <package id="Rainbow" version="2.0.0" targetFramework="net46" />
  <package id="Rainbow.Core" version="2.0.0" targetFramework="net46" />
  <package id="Rainbow.Storage.Sc" version="2.0.0" targetFramework="net46" />
  <package id="Rainbow.Storage.Yaml" version="2.0.0" targetFramework="net46" />
  <package id="Unicorn" version="4.0.3" targetFramework="net46" />
  <package id="Unicorn.Core" version="4.0.3" targetFramework="net46" />
</packages>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.