6

We have found one issue when we add a data source to the field MULTILIST with search it works fine but in case if we add a new language version for that data source then it’s giving only first three records.

Example

Data source values.

1  Argentina – No language version added
2. Armenia -   No language version added
3. Belgium -   No language version added
4. Brazil  -   No language version added
5. DR Congo -  No language version added
6. Ecuador -   No language version added

Without language versions, it’s giving correct data for the selection, below is the screen shot. enter image description here

Issue details-

If we add a new language version for these data source values, As the example below.

1  Argentina –  Added 1 language version
2. Armenia –   Added 1 language version
3. Belgium–    Added 1 language version
4. Brazil –    Added 1 language version
5. DR Congo–   Added 1 language version
6. Ecuador–    Added 1 language version

Below is the reference screenshot where one three records are showing. enter image description here

Note:- We have also tried with Fiddler tools just to track the request and response details, what we have observed here is-

We are getting a response from the backend but somehow it's not showing in the multi-list.

Below is the screenshot from the fiddler response.

enter image description here

Have anyone faced similar issue while using this control(Multilist with search) in multilingual environment, Please suggest

Query for the datasource

StartSearchLocation={56EeeeF8B-272D-4B62-8930-79E1087AD7CE}&Filter=-_name:People&PageSize=210&SortField=_name[asc]

  • What is your sitecore version ? Also please let us know how you have specified source of this field ? – prabhat Sep 19 '17 at 6:26
  • Please share your datasource query in the Multilist with search field template – ABDmaverick Sep 19 '17 at 11:19
  • I just tried this with Sitecore 8.2 update 2 without putting any filter in datasource query but i am not able to replicate this issue.Please provide your Sitecore version and datasource query – prabhat Sep 19 '17 at 11:25
  • @prabhat - Sitecore.NET 8.1 (rev. 160302) March 02, 2016 .NET Framework 4.0.30319.42000 – Jitendra soni Sep 19 '17 at 15:59
  • StartSearchLocation={56ECerwe8B-272D-4B62-8930-79E1087AD7CE}&Filter=-_name:Country&PageSize=210&SortField=_name[asc] – Jitendra soni Sep 19 '17 at 16:42
1

I have raised a Sitecore support ticket (Reference number is 493265), then set up a call to describe this scenario in details, they have reviewed this item and identified as an issue and have provided a fix.

After applying this patch, it's working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.