4

I am setting up personalization on my site (Sitecore 8.2 Update 2).

I have set up rules, pattern cards, etc. but apparently have something wrong.

In Sitecore Experience Editor, I see:

enter image description here

Yeah, you have detected my pattern card correctly!

But yet, the personalization that is setup under Presentation Details seems to be ignored?

enter image description here+

Why the disparity and how do I correct this issue?

6
  • 1
    Did you visit at least 4 pages that have profile info on it? There is a setting in the Sitecore.Analytics.config defining how many pages before pattern/profile tracking works with personalization. <setting name="Analytics.Patterns.MinimalProfileScoreCount" value="3" />
    – Chris Auer
    Sep 26, 2017 at 19:21
  • Are you saying the rules are being ignore while you are in the Experience Editor?
    – Richard Seal
    Sep 26, 2017 at 20:07
  • @RichardSeal, I am Experience "Explorer" mode. Sep 26, 2017 at 20:11
  • @ChrisAuer I have visited over five now, but same thing. Sep 26, 2017 at 20:12
  • 1
    I opened a Sitecore Support ticket on this. Working with @vandsh I am able to see that my code does return true, but for some reason personalization just falls through to the "Default" rule. Sep 28, 2017 at 19:28

1 Answer 1

1

I received a response that this is a bug in Sitecore.

The issue happens due to the Experience Explorer executes the conditions at the time when the contact is already released. The experience explorer processors are executed on the HttpRequestEnd event and the contact is released on HttpRequestProcessed event, which happens earlier.

Contact Sitecore Support if you are experiencing this issue and need the patch file. The reference number for this patch is: 70639

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.