2

I am facing strange issue with Image field in Sitecore. When I "Browse" image field of any item in English Version then I am able to get entire Media Library with its children but when I change the language of same item lets say German and try to "Browse" image field then I getting only media library item and not its children, so I am unable to change the image in other language as shown in below image

enter image description here

Any help will be appreciated.

  • Do the folders containing your assets have German? It could be that the browse dialogue doesn't show folders which don't exist in your context language. – Owen Niblock Oct 8 '17 at 8:39
  • What version of Sitecore – Chris Auer Oct 8 '17 at 20:12
2

I am able to solve this by setting the Source of image field path to "/sitecore/media library/Images" in template. Now instead of showing media library as a starting item, my image field showing "Images" as a starting item on Browse functionality and I am able to get its child items as well.

  • This is best practice anyway. I would strongly recommend that you have dedicated destination folders for any Image fields to prevent cluttering your Media Library. Ideally they'd be further segregated by site/topic, with the ability to create new items limited to the most taxonomically significant folders within each field's Source folder. – Sergeant Sitecore Oct 9 '17 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.