2

I have done something to my environment - In the experience editor, "Editing" and "Designing" check boxes are greyed out, so I cant actually edit anything. Is ExperienceEditor.Enabled a setting somewhere?enter image description here

This is Sitecore 8.2 Update 3

UPDATE

Here is the sites section of my showconfig:

<sites>
    <site name="shell" virtualFolder="/sitecore/shell" physicalFolder="/sitecore/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" loginPage="/sitecore/login" content="master" contentStartItem="/Home" enableWorkflow="true" enableTracking="false" analyticsDefinitions="content" xmlControlPage="/sitecore/shell/default.aspx" browserTitle="Sitecore" htmlCacheSize="10MB" registryCacheSize="15MB" viewStateCacheSize="1MB" xslCacheSize="25MB" disableBrowserCaching="true" contentLanguage="en" patch:source="Delphic.LanguageFallback.config" enableFieldLanguageFallback="false" itemwebapi.mode="StandardSecurity" itemwebapi.access="ReadWrite" itemwebapi.allowanonymousaccess="false" enableItemLanguageFallback="true"/>
    <site name="login" virtualFolder="/sitecore/login" physicalFolder="/sitecore/login" enableTracking="false" database="core" domain="sitecore" disableXmlControls="true" language="en" patch:source="Sitecore.DefaultLanguage.config"/>
    <site name="admin" virtualFolder="/sitecore/admin" physicalFolder="/sitecore/admin" enableTracking="false" enableWorkflow="true" domain="sitecore" loginPage="/sitecore/admin/login.aspx"/>
    <site name="service" enableTracking="true" virtualFolder="/sitecore/service" physicalFolder="/sitecore/service"/>
    <site name="modules_shell" virtualFolder="/sitecore modules/shell" physicalFolder="/sitecore modules/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" content="master" enableTracking="false" enableWorkflow="true"/>
    <site name="modules_website" virtualFolder="/sitecore modules/web" physicalFolder="/sitecore modules/web" rootPath="/sitecore/content" startItem="/home" language="en" database="web" domain="extranet" allowDebug="true" cacheHtml="true"/>
    <site name="MySiteDotCom" hostName="local.mysite.com" errorpageid="26B66A89-8A83-4CD5-80C9-0200F0C7754F" sitesettingsid="FD867206-CB41-4A4E-8C61-C965BD74F5E4" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/MySite DotCom/home" domain="default" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB" patch:source="Delphic.LanguageFallback.config" database="master" filterItems="true" enableWorkflow="true" enableItemLanguageFallback="true"/>
    <site name="MySiteDotNet" hostName="local.mysite.net" errorpageid="9CAA474A-F4F0-4462-A3F3-038B6B3F671D" sitesettingsid="CEC6BC86-5A07-4020-84B0-0A7F2D936664" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/MySite Prepaid DotNet/home" domain="default" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB" patch:source="Delphic.LanguageFallback.config" database="master" filterItems="true" enableWorkflow="true" enableItemLanguageFallback="true"/>
    <!--
     ITEM WEB API SETTINGS FOR A SITE
       Supported attributes (first is default):
         itemwebapi.mode: [Off|StandardSecurity|AdvancedSecurity]
           If set to Off, Item Web API is turned off.
           If set to StandardSecurity, Item Web API is turned on. Default Sitecore security model is used.
           If set to AdvancedSecurity, Item Web API is turned on. Default Sitecore security model is extended with a requirement to explicitely set the 'remote:fieldread' access right for content fields.
         itemwebapi.access: [ReadOnly|ReadWrite]
           If set to ReadOnly, then only READ operation is allowed.
           If set to ReadWrite, then CREATE, READ, UPDATE, and DELETE operations are allowed.
         itemwebapi.allowanonymousaccess: [false|true].
           Defines if access is allowed for non-authenticated user.

    -->
    <site name="website" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/home" database="web" domain="extranet" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB" language="en" patch:source="Sitecore.LanguageFallback.config" itemwebapi.mode="Off" itemwebapi.access="ReadOnly" itemwebapi.allowanonymousaccess="false" enableItemLanguageFallback="false" enableFieldLanguageFallback="false"/>
    <site name="scheduler" enableTracking="false" domain="sitecore"/>
    <site name="system" enableTracking="false" domain="sitecore"/>
    <site name="publisher" domain="sitecore" enableTracking="false" enableWorkflow="true"/>
</sites>
11
  • 1) Are you logged in as an .IsAdministrator user? 2) Does the "site" you are on have Experience Editing enabled?
    – Mark Cassidy
    Commented Oct 11, 2017 at 21:12
  • 1) Yes, I am in as 'admin' 2) How would I enable/disable this? Commented Oct 11, 2017 at 21:33
  • 2
    enableWebEdit="true" on the <site> definition item
    – Mark Cassidy
    Commented Oct 11, 2017 at 21:37
  • Yes, enableWebEdit is true Commented Oct 12, 2017 at 12:41
  • Can you please post the contents of your <sitecore><sites/></sitecore> configuration? Commented Oct 12, 2017 at 15:25

2 Answers 2

2

@wiero pointed me in the right direction...

When I selected any of the ExperienceEditor.EditMode items in the network tab of my browser developer tools, I saw that the error returned was about editing Cookies after the page had loaded, or something similar. It turned out this was something I had done. For very long and convoluted reasons, I am removing the session cookie, to prevent session blocking:

http://johnculviner.com/asp-net-concurrent-ajax-requests-and-session-state-blocking/

But really, I only needed this in the CDs. Having it on the CM broke the Experience Editor. After removing it, everything worked fine.

1
0

I recently had a similar problem where I wasn't able to enable editing nor adding a component on a page.
After further inspection of the network requests, all SPEAK requests were - in my case - blocked because they had no file extension.

To resolve this issue, I had to edit the web.config and allow empty file extensions: Add this fileExtensions to the :

<fileExtensions allowUnlisted="true">
    <remove fileExtension="." />
    <add fileExtension="." allowed="true" />
</fileExtensions>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.