0

I am currently enabling xDB on an Sitecore 8.2.5 install that has recently been upgraded from an 8 initial release. It has never had xDB enabled. I'm getting some issues where data appears to be added to the mongoDB, but when I access the any of the reports I'm getting 404 errors:

somesite/sitecore/api/ao/aggregates/all/786FBA3A4573445EA74504E3CA5E48C1/all?&dateGrouping=by-week&&dateFrom=12-07-2017&dateTo=12-10-2017&keyGrouping=collapsed

Log files don't to show anything out of the normal.

The pages where I see this are the custom analytics graph on the launchpad as well as in the experience analytics dashboard.

I don't really understand why this is happening. The xdb remote processing configs are disabled, the route exists in the routes table:

sitecore/api/ao/aggregates/{site}/{segments}/{keys} 

Has anyone seen this error before? Thanks in advance!

Update

Further on investigation it appears that there isnt any data in the sitecore analytics Facts or Dimensions tables. The following error is in log: enter image description here

I have also started from a clean set of MongoDB's and SQL analytics db.

  • This could be an upgrade issue, maybe you missed a step, Have you tried comparing files/configs of vanilla instance of sitecore with you upgraded instance? – Ahmed Okour Oct 12 '17 at 14:43
  • Hey Ahmed, yup I've tried this. I have compared the vanilla configs and I'm not seeing any differences associated with analytics. I have also compared all the Sitecore binaries and the /sitecore folder using winmerge and am also not seeing any notable differences. – j_r Oct 13 '17 at 0:08
1

It is likely possible that following SqlMappingEntity has been declared more then once.

<SqlMappingEntity type="Sitecore.Analytics.Aggregation.SqlMappingEntity, Sitecore.Analytics.Sql">
    <Table>Fact_FormStatisticsByContact</Table>
    <Routine>Add_FormStatisticsByContact</Routine>
</SqlMappingEntity>

Likely reason: https://kb.sitecore.net/articles/282795

Remove all duplicate SqlMappingEntity elements from your configs and see if this helps.

  • This almost solved the issue as we did have duplicates. The actual issue was related to a customized DefaultHttpControllerSelector which for some reason has blocked access to any routes within the analytics area. The customisation of the httpcontrollerselector was similar to: link – j_r Oct 30 '17 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.