4

This is a Sitecore 8.1 Update 2 installation. I'm getting the errors that are described in this blog post when I try to view the form reports: http://blog.ryanbailey.co.nz/2017/09/sitecore-wffm-form-reports-are-empty.html. It's the triple set of errors, one of which includes

The parameters dictionary contains a null entry for parameter 'id' of non-nullable type 'System.Guid' for method 'System.Web.Mvc.ActionResult GetFormFieldsStatistics(System.Guid)' in 'Sitecore.WFFM.Services.Requests.Controllers.FormReportsController'. An optional parameter must be a reference type, a nullable type, or be declared as an optional parameter. Parameter name: parameters

This is a standalone development machine for now, but in production the CM would be the reporting server as well (it's a 1 CM/2 CD model). Looking at the referenced blog, I confirmed I have the four Sitecore items present, and I have run the SQL script to create the objects in my Sitecore reporting database. I haven't changed any of the default configurations, so it's using the analytics form provider, but this client license doesn't have xDB enabled. In this case, do I need to switch to the SQL form provider instead to capture the data in the form reports?

0

Yes, If you are configured your website in CMS only mode or you can say in xDB disabled mode then you need to follow these steps to configure your reportong properly

First, you need to take the empty Sitecore_Wffm SQL database that was placed in the %webroot%/Data folder and attach it to your SQL Server. Next, you must add a new connection string in App_Config/ConnectionStrings.config for this database.

Yes, the name of this connection string should be wfm. In Sitecore.Forms.config, there is a WFM.ConnectionString setting that specifies the name of the connection string to use. It is wfm out of the box.

**For the record, while this step isn’t in the installation guide for 8.1-compliant versions of WFFM, I have seen it in official documentation somewhere, I just can’t seem to recall where. And if it’s that difficult to find, it’s a problem.

Finally, in Sitecore.WFFM.Dependencies.config, in the /sitecore/wffm/analytics node, there is an element called . By default, this points to the analyticsFormsDataProvider that, according to the comments above it means:

only form’s data from analytics sql and mongo db is involved in reporting (sql) and export (mongo) processes in this case you should be sure that xDb and tracker is on

This should be set to sqlFormsDataProvider.

If you look a little closer at the configuration of the sqlFormsDataProvider in Sitecore.WFFM.Dependencies.config, it ALSO specifies the name of the WFFM connection string rather than reading the WFM.ConnectionString setting from Sitecore.Forms.config. However, it’s wffm. Because, of course. Why not?

Update this connection string name to match what is in Sitecore.Forms.config and you should be golden!

Note- There is an bug in CMS only mode detailed data will not displayed Detailed Reports tab in form report is showing blank in WFFM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.