3

In my Sitecore Experience profile someone contact info. My timeline's time isn't correct. it's show 02:20 in my timeline plugin . but the time is 10:20 in fact. How do I solve this problem? enter image description here

3
  • 1
    Check to see if you are using Server Time zone or Config Time Zone. doc.sitecore.net/sitecore_experience_platform/…
    – Chris Auer
    Commented Oct 26, 2017 at 4:13
  • @ChrisAuer Thank you .Thank you .Thank you . It works. I have changed my Analytics.Reports.DisplayDatesInUtc setting in the App_Config\Include\Sitecore.Analytics.config file
    – Gray
    Commented Oct 30, 2017 at 1:01
  • Awesome, glad to help. If you could mark that answer below as correct, it could help the next person who has this issue.
    – Chris Auer
    Commented Oct 30, 2017 at 1:14

1 Answer 1

1

You should verify that the timezone is set correctly in the config file. If not, it uses the servers time settings.

Server Time Zone

The Server Time Zone setting in the web.config file specifies the server time zone that is used by the server to convert UTC time to local time, for example "GMT Standard Time".

The value must be a valid Time Zone ID in Microsoft .NET. For more information, see http://msdn.microsoft.com/en-us/library/gg154758.aspx

If the value is blank, Sitecore uses the operating system time zone.

  <!--  SERVER TIME ZONE
        This setting specifies the server time zone that is  used by the server to convert UTC time to local time, for example "GMT Standard Time".
        The value must be parsable to a valid Time Zone ID.                   See http://msdn.microsoft.com/en-us/library/gg154758.aspx
        If blank, Sitecore uses the operating system time zone.
        Default value: "" (use the operating system time zone)
  -->
  <setting name="ServerTimeZone" value=""/>

Analytics.Reports.DisplayDatesInUtc

The Analytics.Reports.DisplayDatesInUtc setting in the App_Config\Include\Sitecore.Analytics.config file specifies whether dates and times are displayed in UTC or the local server time zone in the Engagement Analytics reports.

If this setting is set to true, dates and times are displayed in UTC in reports. The default value of the setting is false.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.