3

I have installed Sitecore 8.2 update 5 using the Sitecore Azure Toolkit ARM templates.

The setup is a single CM app service with multiple CD app service instances.

When trying to add an external site to FXM, or even just loading the FXM screen up generates this error in the log files:

2017-10-30T21:59:23 PID[6952] Error 4472 21:59:23 ERROR [Sitecore Services]: HTTP GET URL https://cms-prd-cm.azurewebsites.net/sitecore/api/ssc/domainmatcher/service/DomainMatcher/QueryAll?search=&sorting=aName&skip=0&top=999

Exception Sitecore.ContentSearch.Exceptions.IndexNotFoundException: Index sitecore_fxm_web_index was not found

In my investigation, it looks like the ARM templates are disabling the Sitecore.FXM.Azure.DomainsSearch.Index.Web.config config file when installing the CM instance. On the CD's this is being enabled correctly. Enabling this file does resolve the issue, but is that the right thing to do?

So my questions are:

  • Why is that file being disabled on installation?
  • Should it be disabled?
  • If it should, how do we fix the error where the FXM application is looking for the web index even tho I'm in the CMS admin tool, which should really be looking at the master db and index?
3

I have finally got a response from Sitecore:

There is an inconsistency in Sitecore documentation regarding sitecore_fxm_web_index. Our documentation team is working to fix this inconsistency.

FXM requires that both sitecore_fxm_web_index and sitecore_fxm_master_index are enabled in CM environment.

It will take some time until existing WDPs are updated. Until then you will need to modify the existing WDP package and enable the Sitecore.FXM.Azure.DomainsSearch.Index.Web.config file. In azuredeploy.parameters.json you will need to specify url to modified WDP.

So this is a bug in the way the WDP's are setup. Until these are fixed if you use FXM you will need to create a custom WDP package and use that in your deployments rather than the ones from Sitecore. That should be as simple as:

  1. Download the existing WDP package and unzip
  2. Remove the .disabled extension to the Sitecore.FXM.Azure.DomainsSearch.Index.Web.config file
  3. Zip up that package an upload to your Azure storage account
  4. Update the location of the package in your azuredeploy.parameters.json file

That will make sure that the CM service is correctly configured for FXM.

1

I had the same issue with some of the web-indexes. The indexes I was missing were:

  • sitecore_web_index
  • sitecore_marketingdefinitions_web
  • sitecore_marketing_asset_index_web
  • sitecore_fxm_web_index social_messages_web

These are all defined in configuration files that are only deployed to the CD instances by the ARM templates. By default none of the indexes are set up in the Azure Search Service. They are only created when you first rebuild the indexes.

This is intentional as this is in alignment with the official enable/disable configuration guide (at least for Sitecore 8.2 update 3) which you can find here:

https://doc.sitecore.net/sitecore_experience_platform/82/setting_up_and_maintaining/xdb/configuring_servers/configure_a_content_delivery_server

To create these indexes I logged in to the remove CD ftp server, temporarily enabled access to /sitecore and logged in as admin and rebuilt the indexes. That created them in the Azure Search Service. That fixed the issue for me.

That being said, this shouldn't be necessary for us to do. These indexes should automatically have been created by the ARM templates for us.

I hope this helps.

  • 1
    Getting the index created was not the problem. Visiting the CD instance did that. But FXM seems to need the web index when creating a site. If the web FXM index is disabled on the CM server, you can't create an external site. – Richard Seal Nov 1 '17 at 12:01
  • 1
    Also. If you check that spreadsheet, the fxm web index should be enabled on the CM server. So I think there is a bug in the ARM templates. – Richard Seal Nov 1 '17 at 12:05
  • 1
    I think you are right about the bug in the ARM templates. I've raised a Sitecore support ticket for this as this is related to the issue that I had. But I don't think your error is not related to the index not being defined in your CM instance configuration. Your error is related to the index not being available in your Azure Search Service. Now that you've created the index, I think you can remove that config again, and you won't see that particular error anymore. You may get another one as the enable/disable says it should be on the CM though. I could be wrong :) It's a bug nonetheless. – jonasag Nov 1 '17 at 12:10
  • No I confirmed that the index existed and still had the problem. – Richard Seal Nov 1 '17 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.