6

After disabling Sitecore xDB using the following two settings in the \App_Config\Include\Sitecore.Xdb.config file.

  • <setting name="Xdb.Enabled" value="false" />
  • <setting name="Xdb.Tracking.Enabled" value="false" />

I can still see the following search indexes in my configuration (/sitecore/admin/showconfig.aspx) and activities to maintenance them in log files.

  • sitecore_analytics_index
  • sitecore_marketing_asset_index_master
  • sitecore_marketing_asset_index_web
  • sitecore_marketingdefinitions_master
  • sitecore_marketingdefinitions_web
  • sitecore_testing_index
  • sitecore_suggested_test_index
  • sitecore_fxm_master_index
  • sitecore_fxm_web_index
  • sitecore_list_index
  • social_messages_master
  • social_messages_web

How can I disable xDB related search indexes, when using CMS-only mode?

8

Unfortunately, with Sitecore 8.X series you can't simply go through each configuration file and comment out or delete definitions for the above indexes, because there are many xDB dependencies (defined in configuration files) that don't respect the Xdb.Enabled setting.

Therefore, to disable xDB related search indexes you must remove configuration files with both index definitions and corresponding dependencies (e.g managers/providers/pipelines/processors/tasks etc.).

  1. Remove the following folders under the \App_Config\Include root:

    • CES
    • Channel
    • ContentTesting
    • ExperienceAnalytics
    • ExperienceProfile
    • FXM
    • ListManagement
    • Marketing
    • Social
  2. Remove the following files under the \App_Config\Include root:

    • Sitecore.Analytics.Compatibility.config
    • Sitecore.Analytics.config
    • Sitecore.Analytics.ExcludeRobots.config
    • Sitecore.Analytics.FieldTypes.config
    • Sitecore.Analytics.Model.config
    • Sitecore.Analytics.MongoDb.config
    • Sitecore.Analytics.Outcome.config
    • Sitecore.Analytics.Processing.Aggregation.config
    • Sitecore.Analytics.Processing.Aggregation.ProcessingPools.config
    • Sitecore.Analytics.Processing.Aggregation.Services.config
    • Sitecore.Analytics.Processing.config
    • Sitecore.Analytics.Processing.Services.config
    • Sitecore.Analytics.Reporting.config
    • Sitecore.Analytics.SessionSerialization.config
    • Sitecore.Analytics.Tracking.Aggregation.config
    • Sitecore.Analytics.Tracking.config
    • Sitecore.Analytics.Tracking.Database.config
    • Sitecore.Analytics.Tracking.Database.ScaledCM.config
    • Sitecore.Analytics.Tracking.Outcome.config
    • Sitecore.Analytics.Tracking.RobotDetection.config
    • Sitecore.ContentSearch.Analytics.config
    • Sitecore.ContentSearch.Lucene|Solr|Azure.DefaultIndexConfiguration.Xdb.config
    • Sitecore.ContentSearch.Lucene|Solr|Azure.Index.Analytics.config
    • Sitecore.EngagementAutomation.config
    • Sitecore.EngagementAutomation.Processing.Aggregation.config
    • Sitecore.EngagementAutomation.Processing.Aggregation.ProcessingPools.config
    • Sitecore.EngagementAutomation.Processing.Aggregation.Services.config
    • Sitecore.EngagementAutomation.Processing.config
    • Sitecore.EngagementAutomation.TimeoutProcessing.config
    • Sitecore.EngagementAutomation.Tracking.config
    • Sitecore.ExperienceAnalytics.config
    • Sitecore.Marketing.Client.config
    • Sitecore.Marketing.config
    • Sitecore.MarketingCD.config
    • Sitecore.Marketing.Definitions.MarketingAssets.Repositories.config
    • Sitecore.Marketing.Definitions.MarketingAssets.RepositoriesCD.config
    • Sitecore.Marketing.Definitions.MarketingAssets.Repositories.Lucene|Solr|Azure.Index.Master.config
    • Sitecore.Marketing.Definitions.MarketingAssets.Repositories.Lucene|Solr|Azure.Index.Web.config
    • Sitecore.Marketing.Definitions.MarketingAssets.Repositories.Lucene|Solr|Azure.IndexConfiguration.config
    • Sitecore.Marketing.Lucene|Solr|Azure.Index.Master.config
    • Sitecore.Marketing.Lucene|Solr|Azure.Index.Web.config
    • Sitecore.Marketing.Lucene|Solr|Azure.IndexConfiguration.config
    • Sitecore.Marketing.Search.config
    • Sitecore.Marketing.Taxonomy.config
    • Sitecore.Marketing.TaxonomyCD.config
    • Sitecore.MarketingProcessingRole.config
    • Sitecore.MarketingReportingRole.config
    • Sitecore.MvcAnalytics.config
    • Sitecore.PathAnalyzer.Client.config
    • Sitecore.PathAnalyzer.config
    • Sitecore.PathAnalyzer.Processing.config
    • Sitecore.PathAnalyzer.Services.config
    • Sitecore.PathAnalyzer.StorageProviders.config
    • Sitecore.PathAnalyzer.RemoteClient.config
    • Sitecore.PathAnalyzer.Services.RemoteServer.config
    • Sitecore.Processing.config
    • Sitecore.SegmentBuilder.config
    • Sitecore.Xdb.config
    • Sitecore.Xdb.Remote.Client.config
    • Sitecore.Xdb.Remote.Client.MarketingAssets.config
    • Sitecore.Xdb.Remote.Server.config
    • Sitecore.Xdb.Remote.Server.MarketingAssets.config
  3. Create the Sitecore.Xdb.Off.config under the \App_Config\Include root:

    <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/"> <sitecore> <settings> <setting name="Xdb.Enabled" value="false" /> <setting name="Xdb.Tracking.Enabled" value="false" /> </settings> <appDependencies patch:source="Sitecore.ExperienceAnalytics.config"> <xdb> <app name="Experience Analytics" id="{BCDEDA7A-D6DC-4D2F-9570-7D7F89AAAA0B}"/> <app name="PathAnalyzer" id="{C15CD34F-C772-4B34-84D7-D04E61D72FDB}" patch:source="Sitecore.PathAnalyzer.config"/> <app name="Experience Optimization" id="{2D77A85B-40AD-4376-B44B-1D567B4FE438}" patch:source="Sitecore.ContentTesting.ApplicationDependencies.config"/> <app name="Experience Profile" id="{6111B7F6-B4D9-40B4-A88E-25E3D7760297}" patch:source="Sitecore.ExperienceProfile.config"/> <app name="Federated Experience Manager" id="{254DB1EB-129B-4DBD-9B8E-CC1B38FDD0E7}" patch:source="Sitecore.FXM.Speak.config"/> <app name="List Manager" id="{F7864BD2-ED99-48B7-9C68-C16D0D5624D6}" patch:source="Sitecore.ListManagement.Client.config"/> <app name="Campaign Creator" id="{58961ED8-3E9F-4F3A-8CC7-F0D486524707}" /> </xdb> </appDependencies> </sitecore> </configuration>

  4. Disable Content Testing functionality as described in the Solution (for XP 8.0) section of the following KB article:

  5. Remove the sessionIDManagerType attribute in the Web.config file:

    <sessionState mode="InProc" cookieless="false" timeout="20"> <providers> ... </providers> </sessionState>

Don't keep using Sitecore's session state provider if Sitecore xDB is disabled. Switch to any provider that Microsoft provides for ASP.NET.

If you use Web Forms for Marketers module with , then you should perform additional steps:

  1. Update the \App_Config\Include\Sitecore.Forms.config file as shown below:

    <configuration> <sitecore> ... <ui> <references> <reference patch:before="reference[.='/bin/Sitecore.Forms.Core.dll']">System.dll</reference> <reference uniq="/bin/Sitecore.Forms.Core.dll">/bin/Sitecore.Forms.Core.dll</reference> </references> </ui> </sitecore> </configuration>

  2. Bring back the Sitecore.Marketing.config file under the \App_Config\Include root.

5

You should be able to apply a patch like the following:

<?xml version="1.0" encoding="utf-8" ?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <contentSearch>
      <configuration>
        <indexes>
          <index id="sitecore_analytics_index">
            <patch:delete />
          </index>
          <index id="sitecore_testing_index">
            <patch:delete />
          </index>
          <index id="sitecore_suggested_test_index">
            <patch:delete />
          </index>
          <index id="sitecore_fxm_master_index">
            <patch:delete />
          </index>
          <index id="sitecore_fxm_web_index">
            <patch:delete />
          </index>
          <index id="sitecore_list_index">
            <patch:delete />
          </index>
          <index id="social_messages_master">
            <patch:delete />
          </index>
          <index id="social_messages_web">
            <patch:delete />
          </index>
          <index id="sitecore_marketing_asset_index_master">
            <patch:delete />
          </index>
          <index id="sitecore_marketing_asset_index_web">
            <patch:delete />
          </index>
          <index id="sitecore_marketingdefinitions_master">
            <patch:delete />
          </index>
          <index id="sitecore_marketingdefinitions_web">
            <patch:delete />
          </index>
        </indexes>
      </configuration>
    </contentSearch>
  </sitecore>
</configuration>

You'll need to place this patch near the end of the patching list using a zzz folder. When using Sitecore 9+ you can make use of the config ordering built-in.

You may also want to keep the tracking setting enabled for in-session personalization to work.

Note: There will be additional steps to disable features that tie back to the indexes. For example, some of the content testing features found in the Experience Editor rely on one or more indexes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.