6

I've encountered an issue on Sitecore 8.1 when installing Sitecore PowerShell Extensions. The same issue is happening for other larger packages as well.

This is a vanilla installation. No instance of Mongo Db running.

Update

Adjusted the question to reflect to proper version of Sitecore. Turns out it was 8.1 and not 8.0.

  • 1
    If you don't have Mongo installed, have you explicitly turned off analytics and ip lookups? – Sergeant Sitecore Oct 6 '16 at 19:36
  • I attempted the installation immediately following the Sitecore installer. – Michael West Oct 6 '16 at 19:37
  • 1
    I've seen issues like this (packages not getting installed) when Mongo is not running. Have you tried again with a local Mongo instance for the sake to removing it as a possible cause for the issue? – Eduardo Moraes Oct 6 '16 at 19:47
  • Thanks for the tips. The requirement is to not use Xdb. I'll check to see if disabling it helps. – Michael West Oct 6 '16 at 19:49
  • 1
    I wonder if the indexer is running while your install is still running. Maybe try disabling it during the installation. sitecoreblog.alexshyba.com/…. When I was installing big, 100 mb, packages, I had this issue a lot. – Chris Auer Oct 6 '16 at 19:51
10

Refer to the following:

https://sitecorepowershell.gitbooks.io/sitecore-powershell-extensions/content/troubleshooting.html (edited)

https://kb.sitecore.net/articles/296641

Use this patch config:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
 <sitecore>
   <settings>
     <setting name="Xdb.Enabled">
        <patch:attribute name="value" value="false" />
     </setting>
     <setting name="Xdb.Tracking.Enabled">
       <patch:attribute name="value" value="false" />
     </setting>
   </settings>
 </sitecore>
</configuration>
4

Turns out there is quite a bit to consider with this one. Disabling the Analytics and Xdb are two separate tasks that need to be performed depending on the version of Sitecore.

I ended up creating a new patch.

Sitecore 8.1

Company.Xdb.Config

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <settings>
      <setting name="Xdb.Enabled">
         <patch:attribute name="value" value="false" />
      </setting>
      <!-- Only disable tracking if you don't need it. Leave enabled if you want to personalize within the session. -->
      <setting name="Xdb.Tracking.Enabled">
        <patch:attribute name="value" value="false" />
      </setting>
    </settings>
  </sitecore>
</configuration>

Sitecore 8.0

Company.Analytics.config

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www.sitecore.net/xmlconfig/set/">
  <sitecore>
    <settings>
      <setting name="Analytics.Enabled" set:value="false"/>
    </settings>
  </sitecore>
</configuration>

Other useful links to provide details.

  • This is the most complete answer. Interestingly enough, I've seen this behavior go away immediately after an app-pool recycle as well. Obviously not safe for production :) – user571 Oct 6 '16 at 20:30
  • Yeah, I suppose it is. Wanted to give Akshay the credit since it solved my problem. I just took what he had and enhanced the detail. – Michael West Oct 6 '16 at 20:31
  • 1
    I also didn't even notice that you asked the original question, so there's that... – user571 Oct 6 '16 at 20:52
  • 1
    You don't have to disable Xdb.Tracking.Enabled btw, otherwise you will lose the ability to carry out "session based personalization" – jammykam Oct 7 '16 at 9:28
  • Really JammyKam? Do you have a link with more detail about it? – Michael West Oct 7 '16 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.