In the latest steps, SIF installation process fails because it tries to start the website, but it gets the error below:

Invoke-ManageWebsiteTask : The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have tried to start the website manually through IIS Manager, but it gives me the same error:

enter image description here

Find below the screenshot of the Powershell script execution:

enter image description here

Does anyone have any idea of what is going on?

Update: How I got it fixed?

Firstly, thanks, @artsem-prashkovich and @viet-hoang for the suggestions. You've helped me to figure it out.

Please, find below the steps that I did to get it working:

  1. Restart OS
  2. Stop "Sitecore Marketing Automation Engine" and "Sitecore XConnect Search Indexer" services.
  3. Manually delete the created users from the following databases _Processing.Pools; _MarketingAutomation; _ReferenceData. Each database has its own user: poolsuser, marketing automation user, referencedatauser
  4. Re-run the Powershell installation script


enter image description here

  • you may have to restart the OS in order to overcome the issue (my colleague did it and it worked)
    – Viet Hoang
    Nov 13, 2017 at 11:05

5 Answers 5


It can happen when the apppool is not fully stopped. If it is not first running of power shell script, it first stops the website and then tries to start it again.

Try to restart IIS, stop both windows services, which were already created, and try to start installation again.

  • Thanks for your help, but it didn't work.
    – João Neto
    Nov 13, 2017 at 11:05
  • Try to restart OS, stop both windows services, re-run installation script. If you don’t stop the windows services, You will get the error with Solr cores which you mentioned below Nov 13, 2017 at 12:44
  • I followed the suggested steps. Restart OS > Stop both Windows Services > Re-run installation script. Indeed, that error did not happen. Now I am getting another error: Error: .Net SqlClient Data Provider: Msg 12809, Level 16, State 1, Line 5 You must remove all users with password before setting the containment property to NONE.
    – João Neto
    Nov 13, 2017 at 14:13
  • Yes, it is know issue. Installer can't delete users which were added during first installation. You need to delete it manually for the following databases: _Processing.Pools; _MarketingAutomation; _ReferenceData Each database has own user: poolsuser, marketingautomationuser, referencedatauser Nov 13, 2017 at 14:21

Thanks João Neto for the update on what ended up working for you. This helped out in my installation.

Also commenting to add - after following instructions included here, I was still running into the error. After some reading up on the issue, I realized that Skype was running in the background using port 443 which was causing xConnect installation to fail. Quitting the Skype program helped resolve the issue and installation was successful after that.

  • Nice that it helped you to sort this out. As a golden rule, whenever you are working with something in Windows that requires you to use the 443 port (default HTTP), quit Skype. I had the same issue with Bitnami Solr when working with Sitecore 8. Skype sometimes blocked 443 port and caused the Bitnami service to not start.
    – João Neto
    Feb 28, 2018 at 8:34

I faced a similar issue whilst installing Sitecore 9.1. I installed Solr 7.2.1 as a part of Sitecore installation process. Then realized Solr 6.6.2 was already installed and was running on port 443. Stopped the process and got this working.

You may do netstat -aon | find ":443" to find if any process running on port 443.


Ok I have encountered similar errors so far this is where I have got to

1) Cant start xConnect when Solr is running if I stop Solr I can get the xConnect website to start. So might be something with my install of Solr was using version 6.6.1 so will try 6.6.2

2) Solr cores, I managed to go into the solr admin and unload the cores which seemed to get around the issue mentioned about unable to create core.

3) Had to also stop services sitecore marketing automation engine and Sitecore Xconnect search indexer (these are created for each domain)


Check in command prompt which service using 443 port. In my case "solrApache". I stopped that service and start re-run the script. it's work fine.

Below command help to find which service using this port

netstat -aon | find ":443"

Refer to this blog: https://chebalt.wordpress.com/2017/11/22/sitecore-9-installation-tips/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.