I have created some forms and templates in the Sitecore Forms application, but I can't see them being listed in the grid of the Sitecore Forms main page.

It only displays the message "There are no forms to display.". I've tried to switch to "All forms", "My forms", and "All templates", but all the options give me the same message.

enter image description here

The forms are visible in the Content Tree, though:

enter image description here

The Sitecore logs don't say much

enter image description here

Does anyone know what is going on?

  • 4
    You need to rebuild your index(es) - had this as well, and rebuilding the master index fixed it each time.
    – Gatogordo
    Nov 16 '17 at 15:01
  • 1
    I had the same issue when solr had issue with creating cores. Could you open a solr admin paned and see if there are any errors in the Log? Nov 16 '17 at 15:05
  • Yeah. I figured it out. I noticed some errors on Solr and then I rebuilt my index(es). While I was posting the answer, you've just added this comment! Thanks! =)
    – João Neto
    Nov 16 '17 at 15:06
  • Has rebuilding helped with errors in log? Nov 16 '17 at 15:17
  • @artsem-prashkovich, I don't get those errors anymore. I am getting some warnings, though. 16/11/2017, 15:57:37 WARN false LukeRequestHandler Error getting file length for [segments_1].
    – João Neto
    Nov 16 '17 at 15:22

Basically, I had to rebuild my index(es). I noticed some errors logged on the Solr Admin page, but after rebuilding all indexes, I can see my forms and templates:

enter image description here

enter image description here

  • 1
    that's the reason why I recommend you solr 6.6.2 . on 6.6.1 I have same errors like you on solr logs Nov 16 '17 at 17:15
  • 1
    @SitecoreClimber. I had the same problem on Solr 6.6.2 as well. Rebuilding the Mater DB Index was the solution for me as well. Jan 2 '18 at 20:13
  • one time this solution was work but not 2nd time May 12 '20 at 9:41

I also followed all mentioned steps but still I was unable to see the forms. In Chrome developer tools I noticed I got a 403 Forbidden when requesting


Then I started to look further on 403 reponses on SC API requests. Eventually this led me to a suggestion to clear all my browser cookies. This solved the issue for me.

  • I think It would be better if you create a new question and describe you issue and steps that you've done to solve. It will be much more effective than to put a question as an answer to another question. Feb 7 '19 at 8:37
  • rebuild index was 1st time 2nd time your solution work thank you very much ! May 12 '20 at 9:42

I followed the below blog to fix my issue which as clear troubleshooting steps.


  1. I tried re-build index (didn't work)
  2. Rename forms from content editor (worked)

Then I was able to see disappeared in forms application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.