16

I'm installing the Sitecore 9 XP0 locally and struggling with the following problem: installation process fails with the following error:

Unable to connect to master or target server 'xp0_Processing.Pools'. You must have a user with the same password in master or target server 'xp0_Processing.Pools'.

The error occurs on Deploying package to database stage.

My install.ps1 is created from the official Sitecore Installation Guide, $SqlAdminUser, $SqlAdminUser and $SqlAdminPassword parameters are set correctly.

What can be the reason here?

  • Could you check your credentials to the SQL Server? Can you login to the SQL Managment Studio with them? And which version of SQL have you installed? – Artsem Prashkovich Nov 21 '17 at 17:01
  • SQL Credentials are fine I double-checked them. The SQL Version is 14.0.1000.169 (2017 Express) – A. Dylevich Nov 21 '17 at 17:07
  • Another potential 'Gotcha', my SQL password had a '$' sign in it, which needs to be escaped (ie, use single quotes around it, instead of dbl quotes) – Jamie Scott Feb 14 '18 at 23:14
  • Adding "localhost" to the SQLServer string worked for me... – Dan Blackman Jun 11 '18 at 20:55

10 Answers 10

14

I had the same issue when I tried to install Sitecore 9 with MS SQL Server 2017. The Sitecore 9 has the MS SQL Server 2016 in the prerequisits. Unfortunatelly it looks like the newer versions are not supported.

Try to install the MS SQL Server 2016 and re-run the installation.

  • Indeed! I installed the MS SQL 2016 sp1 Express and now database installation works. Thanks, @artsem-prashkovich! – A. Dylevich Nov 21 '17 at 17:55
  • 1
    I haven't had any apparent issues with SQL Server 2017 Developer and Sitecore 9 (XP0) – Søren Kruse Nov 28 '17 at 18:29
  • FWIW - I had a different error with SQL 2017 sp 2 enterprise, but got this exact error with SQL 2016 sp 2 enterprise.Will uninstall and try SQL 2016 sp 1 and report back. – MikeD Sep 8 '18 at 3:19
  • welp! - Found out the it was a typo in the sql server variable value the whole time in my case. – MikeD Sep 8 '18 at 4:00
3

You can also run in to this error when the credentials are not correct for $SqlAdminUser and $SqlAdminPassword for the SQL instance specified in $SqlServer, from the PowerShell script on page 34 of the installation guide.

  • Haha, thanks! My password was Stuff1234567, and I used Stuff123457 by mistake. Noticed this thanks to you! :) – Dmytro Shevchenko Aug 2 '18 at 8:25
3

I have successfully installed Sitecore 9 with MS SQL Sever 2017 Express. I had encountered the same error and the trick is instead of using $SqlServer="localhost" in the installation script, change it to $SqlServer="localhost\SQLExpress". If you are indeed using the Express version, doing so should avoid the above issue!

  • 2
    or SQLExpress instead of localhost\SQLExpress :-) – TamerM Dec 20 '17 at 13:38
2

Basically this error comes when xConnect setup script is not able to connect to SQL server.

Try following solutions :

1) Please check whether SQL Server credentials contains $ , powershell will ignore characters after $ , remove $ and then try.

2) If it still gives error , try looking into this blog by Brandon Bruno. https://www.sitecorespark.com/blog/2017/11/sitecore-installation-framework-error-processing-pools

1

Mine was in SQL server 2016 only. I did not need to install 2017 or re install 2016 again. I have modified the following attributes on install.ps1 according to my local machine settings and that fixed the issue.

$SqlServer = "localhost(SQL server instance name if server name is not localhost)"
$SqlAdminUser = "sa"
$SqlAdminPassword = "12345" 
0

Its always better... whatever you are giving the value, please use the same in SQL Server Management Studio..

If you are able to connect using SQL Server Management Studio, use the same details in your powershell script file while installing Sitecore 9.0 or Sitecore 9.0 Update -1.

0

In my case the user "sa" was locked out. I had to unlock it in SSMS. Expand the server => Security => Logins => "sa", rightclick => "properties" => "status" => Uncheck "login is locked out"

0

I have installed both Sitecore 9 and 9.1 using the SIF and SQL Server 2017. I have come accross the issue specified in this question but the key is to ensure your paramters for SQL server are correct. As long as you can log into SQL Server using the 3 parameters specified below and you have set the user "sc91" as SysAdmin it will work

in my powershell script, my SQL Server parameters are...

$SqlServer = "JG-LAPTOP\SQLEXPRESS"
$SqlAdminUser = "sc91" 
$SqlAdminPassword="CP~~45%sd{}ee]%P)B"

my version of SQL Server 2017 is...

Microsoft SQL Server 2017 (RTM-CU6) (KB4101464) - 14.0.3025.34 (X64)
Apr 9 2018 18:00:41 Copyright (C) 2017 Microsoft Corporation Express Edition (64-bit) on Windows 10 Pro 10.0 (Build 16299: )

for more info view this blog -> https://www.sitecorespark.com/blog/2017/11/sitecore-installation-framework-error-processing-pools

0

After getting this issue myself trying to set up a new machine you will have issues if you have SQL Server 2017 and use only the dependencies mentioned in the installation guide.

Turns out the trouble is that the DacFx version linked to in the installation guide only works for SQL Server 2016 and you have to download a later version:

Microsoft® SQL Server® Data-Tier Application Framework (17.0.1 DacFx) https://www.microsoft.com/en-us/download/details.aspx?id=55114

Once I installed this version I had no trouble running the scripts.

0

I encountered with this error when my install script had $SqlServer = “Servername” defined as the value for $SqlServer was not correctly assigned.

Code did not work

This correct value for $Sqlserver parameter should be “$SqlServer = “.\Servername” or “machinename\Servername” or “localhost\Servername”.

enter image description here

You can use “Data Link Properties” utility to check the connectivity with SQL server from your client following below steps:

  1. Create a blank text file (From Desktop of client machine Right click >> New>>Text Document
  2. Change the extension of file to “. udl” from “.txt”
  3. Double Click on that file
  4. Enter your SQL Server Name (.\SQLServerInstanceName) on the Data Link Properties dialog
  5. Enter sql credentials (same as used in install script)
  6. Click “Test Connection” button, if you see “Test Connection Succeeded” message, your Script should work as long as you have same values defined for $SqlServer, $SqlAdminUser and $SqlAdminPassword parameters

Test SQL Connectivity from Client using Data Link Properties

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.