I'm installing the Sitecore 9 XP0 locally and struggling with the following problem: installation process fails with the following error:

Unable to connect to master or target server 'xp0_Processing.Pools'. You must have a user with the same password in master or target server 'xp0_Processing.Pools'.

The error occurs on Deploying package to database stage.

My install.ps1 is created from the official Sitecore Installation Guide, $SqlAdminUser, $SqlAdminUser and $SqlAdminPassword parameters are set correctly.

What can be the reason here?

  • Could you check your credentials to the SQL Server? Can you login to the SQL Managment Studio with them? And which version of SQL have you installed? Commented Nov 21, 2017 at 17:01
  • SQL Credentials are fine I double-checked them. The SQL Version is 14.0.1000.169 (2017 Express) Commented Nov 21, 2017 at 17:07
  • 1
    Another potential 'Gotcha', my SQL password had a '$' sign in it, which needs to be escaped (ie, use single quotes around it, instead of dbl quotes) Commented Feb 14, 2018 at 23:14
  • Adding "localhost" to the SQLServer string worked for me... Commented Jun 11, 2018 at 20:55

12 Answers 12


I had the same issue when I tried to install Sitecore 9 with MS SQL Server 2017. The Sitecore 9 has the MS SQL Server 2016 in the prerequisits. Unfortunatelly it looks like the newer versions are not supported.

Try to install the MS SQL Server 2016 and re-run the installation.

  • Indeed! I installed the MS SQL 2016 sp1 Express and now database installation works. Thanks, @artsem-prashkovich! Commented Nov 21, 2017 at 17:55
  • 1
    I haven't had any apparent issues with SQL Server 2017 Developer and Sitecore 9 (XP0) Commented Nov 28, 2017 at 18:29
  • FWIW - I had a different error with SQL 2017 sp 2 enterprise, but got this exact error with SQL 2016 sp 2 enterprise.Will uninstall and try SQL 2016 sp 1 and report back.
    – MikeD
    Commented Sep 8, 2018 at 3:19
  • welp! - Found out the it was a typo in the sql server variable value the whole time in my case.
    – MikeD
    Commented Sep 8, 2018 at 4:00
  • yes its true same for me Commented Dec 4, 2019 at 12:53

I have successfully installed Sitecore 9 with MS SQL Sever 2017 Express. I had encountered the same error and the trick is instead of using $SqlServer="localhost" in the installation script, change it to $SqlServer="localhost\SQLExpress". If you are indeed using the Express version, doing so should avoid the above issue!

  • 3
    or SQLExpress instead of localhost\SQLExpress :-)
    – TamerM
    Commented Dec 20, 2017 at 13:38

You can also run in to this error when the credentials are not correct for $SqlAdminUser and $SqlAdminPassword for the SQL instance specified in $SqlServer, from the PowerShell script on page 34 of the installation guide.

  • Haha, thanks! My password was Stuff1234567, and I used Stuff123457 by mistake. Noticed this thanks to you! :) Commented Aug 2, 2018 at 8:25

Basically this error comes when xConnect setup script is not able to connect to SQL server.

Try following solutions :

1) Please check whether SQL Server credentials contains $ , powershell will ignore characters after $ , remove $ and then try.

2) If it still gives error , try looking into this blog by Brandon Bruno. https://www.sitecorespark.com/blog/2017/11/sitecore-installation-framework-error-processing-pools


After getting this issue myself trying to set up a new machine you will have issues if you have SQL Server 2017 and use only the dependencies mentioned in the installation guide.

Turns out the trouble is that the DacFx version linked to in the installation guide only works for SQL Server 2016 and you have to download a later version:

Microsoft® SQL Server® Data-Tier Application Framework (17.0.1 DacFx) https://www.microsoft.com/en-us/download/details.aspx?id=55114

Once I installed this version I had no trouble running the scripts.

  • 2
    This was the issue for me as well when trying to install 9.2 using SIF and SQL Server 2017. I ended up needing to use a later version of DacFx (18.0.1) and, most importantly, needed to install both x86 and x64 versions of the DacFx .msi installer.
    – Adam Weber
    Commented Nov 26, 2019 at 0:00

Mine was in SQL server 2016 only. I did not need to install 2017 or re install 2016 again. I have modified the following attributes on install.ps1 according to my local machine settings and that fixed the issue.

$SqlServer = "localhost(SQL server instance name if server name is not localhost)"
$SqlAdminUser = "sa"
$SqlAdminPassword = "12345" 

Also if deploying on dev or production environments, make sure server can access sql databases.You can check it by following adding "TestSQL.UDL" on server desktop and check if it can access database server. Check this link to make sure connectivity is not the issue - https://dba.stackexchange.com/questions/23704/easy-way-to-check-connectivity-to-sql-server-from-client


In my case the user "sa" was locked out. I had to unlock it in SSMS. Expand the server => Security => Logins => "sa", rightclick => "properties" => "status" => Uncheck "login is locked out"


Its always better... whatever you are giving the value, please use the same in SQL Server Management Studio..

If you are able to connect using SQL Server Management Studio, use the same details in your powershell script file while installing Sitecore 9.0 or Sitecore 9.0 Update -1.


I have installed both Sitecore 9 and 9.1 using the SIF and SQL Server 2017. I have come accross the issue specified in this question but the key is to ensure your paramters for SQL server are correct. As long as you can log into SQL Server using the 3 parameters specified below and you have set the user "sc91" as SysAdmin it will work

in my powershell script, my SQL Server parameters are...

$SqlAdminUser = "sc91" 

my version of SQL Server 2017 is...

Microsoft SQL Server 2017 (RTM-CU6) (KB4101464) - 14.0.3025.34 (X64)
Apr 9 2018 18:00:41 Copyright (C) 2017 Microsoft Corporation Express Edition (64-bit) on Windows 10 Pro 10.0 (Build 16299: )

for more info view this blog -> https://www.sitecorespark.com/blog/2017/11/sitecore-installation-framework-error-processing-pools


I encountered with this error when my install script had $SqlServer = “Servername” defined as the value for $SqlServer was not correctly assigned.

Code did not work

This correct value for $Sqlserver parameter should be “$SqlServer = “.\Servername” or “machinename\Servername” or “localhost\Servername”.

enter image description here

You can use “Data Link Properties” utility to check the connectivity with SQL server from your client following below steps:

  1. Create a blank text file (From Desktop of client machine Right click >> New>>Text Document
  2. Change the extension of file to “. udl” from “.txt”
  3. Double Click on that file
  4. Enter your SQL Server Name (.\SQLServerInstanceName) on the Data Link Properties dialog
  5. Enter sql credentials (same as used in install script)
  6. Click “Test Connection” button, if you see “Test Connection Succeeded” message, your Script should work as long as you have same values defined for $SqlServer, $SqlAdminUser and $SqlAdminPassword parameters

Test SQL Connectivity from Client using Data Link Properties


I had this issue with Sitecore 9 and using SQL Server 2017 Developer Edition to setup Sitecore on my local environment.

In the sitecore-XP0.json configuration file I had to replace

"SqlServer": {
      "Type": "string",
      "DefaultValue": ".\\SQLSERVER",
      "Description": "The Sql Server where databases will be installed."


"SqlServer": {
      "Type": "string",
      "DefaultValue": "(local)",
      "Description": "The Sql Server where databases will be installed."

I assume (.) would have also have worked.


For me the solution was to install an older version of SSDT. release 17.4 for VS 2015. https://docs.microsoft.com/en-us/sql/ssdt/previous-releases-of-sql-server-data-tools-ssdt-and-ssdt-bi?view=sql-server-2017

I am using VS2017 and SQLServer 2017

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.