1

I created a custom validator for a multi-list field which checks the number of selected items based on the min and max count set in a configuration item. On debug mode, the validator is being called and is returning the expected results. Sitecore also displays the pop-up message saying that validation errors needs to be resolved first before the item can be saved. However, the red vertical line displayed on the left side of the field along with the custom validator's error message are not displayed realtime (they only get displayed when i click the top right part of the content tab - the side where small red / yellow boxes appears when there are field errors). I've added the validators for all validation rules fields (such as quick action bar, validate button, validator bar, and workflow).

Am I missing any configurations? How could we trigger Sitecore to display the validation message realtime?

Note: I've tried creating custom validator using Sitecore 8.0 and it's working as expected. Issue occurs when I'm using Sitecore 8.2 Update 4.

Thanks, GC

3
  • 1
    could you provide configuration of your custom rule in Sitecore? Nov 30 '17 at 9:02
  • I've added a Validation Rule item under /sitecore/system/Settings/Validation Rules/Field Rules linked to a class that inherits StandardValidator. The implemented Evaluate method returns a FatalError when input is deemed to be invalid. Is this the configuration you are referring to?
    – user2816
    Dec 5 '17 at 1:45
  • Just to add, upon further investigation, we found out that the validation error message is not displayed only when the Evaluate method returns a FatalError (the correct validation message is displayed when the newly inputted data is allowed to be saved using the CriticalError or the other ValidatorResult types).
    – user2816
    Dec 5 '17 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.