4

I'm using Sitecore version 8.1 update 3. If an item has multiple versions created and I change publishing restrictions on a version, using the Publish Settings window, a change to 1 version modifies all of them.

Start:

Before making change to restrictions

  1. Open the Publish Settings dialog (i.e. Publish tab -> Change)
  2. On the Versions tab, change the publishable date on the newest version
  3. Click OK.
  4. Now check the statistics on any of the versions.

It's now showing this:

Updated Item Versions

Any ideas?

1

I tried to reproduce the issue you highlighted above. When I update the most recent version, which is version 5, it shows the correct results, which is that only that version was updated with my change. I tried this with Sitecore 8.1.3.

Also I reviewed the code in the Sitecore.Client dll and I don't see any reason it would cause that issue either. Basically as it loops through the versions collection when the user clicks on the OK button, it will do a conditional check to see if the value is set to Hide version or else the current unsaved to and from dates are different from the values entered. It will not compare seconds, just minutes and date information.

If you are still having issues and maybe you had slightly different steps to follow, than in this scenario, it's probably going to be best to reach out to Sitecore support.

However if you can't wait and need to solve this right away or hack it so it works, you can also optionally, override the command that is firing the dialog to load, and you can either use dotpeek to build a similar dialog to the one that is OOTB from Sitecore or you could rewrite their dialog.

To change the command that runs, you just need to patch the type attribute to your own method from the line below:

<command name="item:setpublishing" type="Sitecore.Shell.Framework.Commands.SetPublishing, Sitecore.Kernel" />

That will fire off the dialog from that command method, the dialog code can be found in the front end interface located here: Website\sitecore\shell\Applications\Content Manager\Dialogs\Set Publishing\Set Publishing.xml. You could obviously also update that file, but I wouldn't recommend that since it's not upgrade friendly.

  • 1
    I did a fresh install using the installer for 8.1 update 3... and fresh install, I could reproduce it.... so not sure why this seems to be random for some? Either way, I chose this as the answer because you were right on in what needed to be done. I actually found that someone had done this for version 6.6, but with a some updates, I was able to make it work. bitbucket.org/nsgocev/publishing-restrictions/overview Thanks for pointing me in the right direction! – divamatrix Dec 6 '17 at 3:42
  • Absolutely, glad I could help! – Dylan Young Dec 6 '17 at 4:23
0

I tried to replicate this issue on Sitecore 8.1 Update 3 and on Sitecore 9,

I didn't find any issue on Sitecore 9 but on Sitecore 8.1 Updated 3, I have noticed this once but now it's working fine, looks like a random issue. enter image description here

Looks like this is related to Hide version checkbox under lifetime section(Standard template).

I faced a similar problem while using the checkboxes, these values randomly got deselected, After discussing with Sitecore support team (Ticket Ref -494455), I came to know this is an issue in Sitecore 8.1 version and had fixed in release 8.2

I got a patch from the Sitecore team and after applying that patch similar issue of checkboxes got resolved.

Please refer to TFS number 107694,

Sitecore release note:- https://goo.gl/61J3Le

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.