10

Working on a Multilingual Implementation on Sitecore Version 8.1 rev. 160302 (Update-2) with 7 languages.

We are experiencing a random and strange behavior with Check-boxes (In my case).

Scenario and steps to reproduce are as follows:

Page Template has Multiple Check-boxes.

  1. Create a content item using the template in English-Us Version.
  2. Create language versions of this item.
  3. While creating language versions, sometimes the Check-boxes are Unchecked Automatically.
  4. Unfortunately we are unable to track any specific pattern for this. As the content editor team is experiencing is randomly.

Wanted to check with the community if anyone else is also experiencing the same behavior. If yes, did you find any root cause or work around?

  • Is it the same checkboxes that randomly become unchecked? Do you have any custom events for item:saved that might be affecting this? Is it also possible that you've created language versions for the __standard values for the item you are working with, and when you create an item in a version that it's pull from there those checked/unchecked values but those values would be configured differently for a different language __standard values.. – Dylan Young Dec 2 '17 at 3:42
  • Thank you for the quick response @DylanYoung. Its not the same Check box always though, its all random. No we don't have any custom event and we also don't have language versions for Standard values. – Amitabh Vyas Dec 2 '17 at 3:57
  • Absolutely, unfortunately I'm not aware of any reason you would get truly random check or unchecked boxes, course nothing is truly random in the end :-) – Dylan Young Dec 2 '17 at 4:13
  • Agree, we are also trying to track any particular pattern or behavior. Will keep posted here if I find anything specific. – Amitabh Vyas Dec 2 '17 at 4:15
6

I noticed a similar problem while using Check-boxes, the values are randomly unchecked.

I did a lot of QA and R&D to identify the issue or pattern, Finally, I was able to create a video where clearly capture the Check-boxes got unchecked.

I executed similar steps to create multiple versions of an item in different languages. After continuously trying these similar steps, I observed this once in a while.

After discussing with Sitecore support team, I came to know this is an issue in Sitecore 8.1 version and has fixed in release 8.2

I got a patch from the Sitecore team and after applying that patch similar issue of Check-boxes got resolved.

please refer to TFS number 107694,

Sitecore release note:- https://goo.gl/61J3Le

  • Hello Jitendra, seems it is the same kind of issue. Let me have a look at the release notes and ask the Sitecore support for the patch. Will test and update you accordingly. – Amitabh Vyas Dec 2 '17 at 4:45
  • Installing the patch resolved the problem. Patch contains the fixes for Checkboxes, Droplink and Droplists loosing the values when switching from one item to another with unsaved changes. It was an issue identified under TFS # 107694 on release notes mentioned below: dev.sitecore.net/Downloads/Sitecore%20Experience%20Platform/82/… Thanks Jitendra. – Amitabh Vyas Dec 4 '17 at 22:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.