5

I am trying to install Sitecore 9.0 on Windows Server 2012 Update R2.

I have followed all steps mentioned in this article: https://blogs.perficient.com/microsoft/2017/10/how-to-install-sitecore-9-with-the-sitecore-install-framework/

Here is the current Status:

  1. Powershell version: 5.2
  2. SOLR 6.6.2 with SSL enabled
  3. Successfully executed prerequisites i.e.
    • Register-PSRepository -Name SitecoreGallery -SourceLocation https://sitecore.myget.org/F/sc-powershell/api/v2
    • Install-Module SitecoreInstallFramework
    • Install-Module SitecoreFundamentals
    • Import-Module SitecoreFundamentals
    • Import-Module SitecoreInstallFramework

Finally, when i tried to execute Sitecore installation powershell script, i am getting below exception...

Install-SitecoreConfiguration : No matching commands include a parameter named 'Signer'.  Check the spelling of the parameter name, 
and then try again.
Parameter name: Signer
At C:\sitecore\install\sc9-v2.ps1:18 char:1
+ Install-SitecoreConfiguration @certParams -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration 

Please suggest, how can we resolve this issue?

Thanks,

  • did you solved your problem ? I wrote my experience about installing Sitecore 9 on Windows 8.1, but will be the same steps in terms of the certificate also for Windows Server 2012 R2. xtremdev.wordpress.com/2018/01/08/… Please check it out. – Sebastian Tecsi Jan 8 '18 at 13:18
2

This is a known issue: SIF doesn't support IIS 8.0

You need to generate the certificates manually and then continue with the installation. Alternatively you could extend SIF and call your own version of New-SignedCertificate.ps1 to handles signing of certs for Win 8.1 & Server 2012 .

enter image description here

  • Hi @Sitecore Climber, I tried to generate the certificates manually Exported with.. Export-PfxCertificate -cert $signedCertificate -FilePath $exportPFXFilePath -Password $pwd2 and imported with.. Import-PfxCertificate -FilePath $exportPFXFilePath -CertStoreLocation Cert:\LocalMachine\Root -Password $pwd2 -Exportable but now it gives another issue. "Cert:\Localmachine\My\D9685E328FBC652C9D345D8F996620723E6264C9 does not contain Private Key. Ensure that it has been exported with the Private Key." It will be good if you can elaborate your answer. Thanks for your quick reply – Arvind Gehlot Dec 4 '17 at 11:25
0

Check out this detailed video, it might be useful by Chris Auer https://www.youtube.com/watch?v=82luFi83Gl0

0

Use latest version of Sitecore Installation Framework (SIF) 1.2 which is solving issue with certificate creation on Windows Server 2012 R2.

See release notes here -> https://dev.sitecore.net/Downloads/Sitecore%20Installation%20Framework/1x/Sitecore%20Installation%20Framework%2012/Release%20Notes

SIF 1.2 Download page -> https://dev.sitecore.net/Downloads/Sitecore_Installation_Framework/1x/Sitecore_Installation_Framework_12.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.