6

We're using Branches in Sitecore 8.1 rev. 160519 when creating new pages. However, at some point a branch item was lost in all of our environments, possibly because of a bad package, since the item doesn't exist in the recycle bin.

This has resulted in a number of items displaying when we scan for broken links, since the Created from field is no longer pointing to a valid item, and is displaying the following in the Content Editor:

"[branch no longer exists] - {00000000-0000-0000-0000-000000000000}"

The pages themselves work without issue, so this seems to be an issue just behind the scenes, that doesn't actually impact rendering. However, we would like to fix these broken references.

How can we go about correcting this broken link? We've recreated the branch, so ideally we'd like to point to that, or just remove the reference (as that seems to be fine, based upon other items in Sitecore).

I've tried looking at the items via an older version of Razl (2.5) as well as the current version of Sitecore Rocks.

  • This could also be done through editing TDS Items in Visual Studio. Thanks for this. – D0cNet Mar 28 '17 at 18:34
7

As a workaround, please perform the following steps:

  1. Create a backup before making any changes.

  2. Serialize the problem item (Developer > Serialize > Serialize Item).

  3. Open the created file (Data\serialization\dbname\itempath\itemname.item) with a text editor and set the master parameter:

    Master: {00000000-0000-0000-0000-000000000000}
    
  4. Save changes.

  5. Revert the item in Sitecore (Developer > Serialize > Revert Item).

For more information see sections 2.2.2 (Serializing Items) and 2.4.2 (Reverting Items) of the Sitecore Serialization Guide.

  • Does this work in terms of solving a similar issue, where installing items via a Sitecore package looses the 'created from' as well? – Søren Engel Sep 21 '16 at 20:19
  • @SørenEngel Could you expand upon what you mean? I believe that's why we ran into this issue because of packaging and this solution worked fine. – James Skemp Sep 22 '16 at 13:32
  • for consistency I believe this should be a lowercase "m" in master – Sabel Jul 30 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.