2

I am using Lucene search engine.

When using drop link field in SXA facets component, it displays GUID,

I see other posts talking about this issue, and in order to fix it, we should change the below settings to true in sitecore.buckets.config

<setting name="BucketConfiguration.ResolveFacetValueToFriendlyName" value="**true**"/>

But After changing it still facet Component is displaying GUID. Any pointer for this issue would highly appriciated.

  • I assume you are talking about the BucketConfiguration.ResolveFacetValueToFriendlyName setting, but could you mention that in your question - and maybe share a screenshot or some extra information? – Gatogordo Dec 7 '17 at 8:48
  • Yep, some screenshots might be helpful. – Dawid Rutkowski Dec 7 '17 at 9:04
2

You need to check this part of the documentation: https://doc.sitecore.net/sitecore_experience_accelerator/setting_up_and_configuring/configuring/extend_search#_Extend_search_to_3

This explains how to use a link type field in the facets. Add a computed field and use that fieldname in the facet:

Add the following definition to your search configuration file:

<field fieldName="referenced"
  type="Sitecore.XA.Foundation.Search.ComputedFields.ResolvedLinks, Sitecore.XA.Foundation.Search" 
  referenceField="link"
  contentField="title"/>

where:

fieldName – attribute that defines the index field name where the value will be stored.

referenceField – attribute that defines the field name of the indexed item.

contentField – attribute that defines the field of the referenced item from which the value will be retrieved during the indexing.

Don't forget to rebuild your index after the change.

Not the answer you're looking for? Browse other questions tagged or ask your own question.