4

While installing Sitecore 9 XP0 on a new Windows 10 VM I came across the following error.

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information: Module IIS Web Core Notification
BeginRequest Handler Not yet determined Error Code 0x80070021 Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false". Config File
\?\C:\inetpub\wwwroot\sc90.sc\web.config Requested URL
http://sc90.sc:80/ Physical Path C:\inetpub\wwwroot\sc90.sc Logon Method Not yet determined Logon User Not yet determined

Config Source: 73: 74: 75:

More Information: This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error. View more information »

8

The error points to a lock on the IIS configuration. However, after some research, I came across to the solution which I share here hoping it will save someone else's time.

The reason for the error is that ASP.NET, one of the prerequisites, was not installed. The interesting thing is that Windows 10 doesn't show the ASP.NET feature on its "Windows Features" window (Turn Windows features on or off) therefore it cannot be enabled as before.

The way to enable ASP.NET in Windows 10 is by executing the following command in a console as Administrator:

dism /online /enable-feature /all /featurename:IIS-ASPNET45

When ASP.NET is installed the applicationHost.config (in %windir%\system32\inetsrv\config) gets updated unlocking some configuration sections that are updated by Sitecore's web.config file. And this solves the issue.

  • 1
    Its worth noting that this fix isn't unique to 9.0, I just used it for a new 8.0 site as well. – GoetzOnline Jun 12 '18 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.