1

Language fallback not working in Sitecore 9.0 with SXA 1.5. I have done the below changes to enable language fallback(en) for all added languages.

  • On the System Languages in Sitecore Select the language fallback option as "en" for all the languages created.

  • Add patches for Sitecore.LanguageFallback.config
    enter image description here

  • Doing the same for sitecore_master_index and sitecore_web_index in Sitecore.ContentSearch.Solr.Index.Master.config and Sitecore.ContentSearch.Solr.Index.Web.config respectively.

  • Enable the Item Language and Field level fallback checkbox on the template of the item standard values and fields.

Am I missing something? Please help

5

Step 2. From what I can see you've patched settings for two sites: shell and website

If your goal is to enable language fallback for SXA sites you have to do the same for them. The difference is that SXA sites definitions are stored in a database, so you have to update items.

  1. Find your site definition item: /sitecore/content/Folder/Tenant/Site/Settings/Site Grouping/S
  2. Extend SXA site attributes

enter image description here

  • I do see the Item level fallback check box here also. Do I need this flag to be selected inside Site Grouping for the Site – Amitabh Dec 12 '17 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.