5

I've done an upgrade of Sitecore 8 to 8.1 update 3. I notice that this version of Sitecore references version 1.10.0.62 of MongoDB.Bson and MongoDB.Driver. Where can I find these NuGet packages? I've looked on nuget.org but that only seems to have version 2 onward.

  • They are the in bin of your Sitecore zip file, aren't they? Do you need them as nuget packages? – Marek Musielak Oct 7 '16 at 14:45
  • Yep, I've got the DLLs themselves, I just need them in a package! – Matthew Dresser Oct 7 '16 at 14:46
6

The package was renamed on nuget, what you want is the mongocsharpdriver package. You can get 1.10.0.62 by using:

Install-Package mongocsharpdriver -Version 1.10.0

That package contains boths MongoDB.Driver.dll and MongoDB.Bson.dll.

Here is the nuget page for the older project:

https://www.nuget.org/packages/mongocsharpdriver/

Which has now been renamed to:

https://www.nuget.org/packages/MongoDB.Driver/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.