0

I am trying to set up my local development environment to work with WFFM. I have installed a clean instance of Sitecore 8.1 (rev. 151207) and Web Forms for Marketers 8.1.rev. 151008. I followed all of the configuration instructions located here: https://doc.sitecore.net/Web%20Forms%20for%20Marketers/82

I configured a local hMailServer using the instructions found here: https://community.sitecore.net/technical_blogs/b/getting_to_know_sitecore/posts/local-mail-servers-amp-sitecore

I updated the Sitecore.Forms.config with my hMailServer settings. I also added these settings to the standard Sitecore Send Email Message save action: /sitecore/system/Modules/Web Forms for Marketers/Settings/Actions/Save Actions/Send Email Message.

I checked Client Action on the Send Email Message save action and I removed the following line from Sitecore.Forms.config:

<setting name="WFM.IsRemoteActions" value="true" />

I created a simple form and set it to send a message to the Email address the user entered. I am able to enter data into the form, click submit, and I see the success thank you message.

I verified that all forms and save actions are published to the web database.

No email is ever sent. No information is in the logs or the event viewer to point me to any error in my setup. No emails are in the queue in hMailServer. What am I missing?

0

I fixed this by wiping out the instance and starting fresh. I'm guessing I missed a step somewhere along the way. It works now and the email is sending as expected.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.