8

I am in process of installing Sitecore 9 using SIF. Everything went smooth but when running the Power shell script to install SIF, ended up with the error below:

PS>TerminatingError(Invoke-CopyTask): "Cannot validate argument on parameter 'Source'. The " Test-Path $_ " validation script for the argument with value "D:\Sitecore9\solr-7.1.0\server\solr\configsets\basic_configs*" did not return a result of True. Determine why the validation script failed, and then try the command again."

Any input are appreciated.

Pre-requisites are as follows:

  1. Windows 10
  2. Solr 7.1.0
  3. Visual Studio 2017 Community Edition
  4. SQL 2016 Express
  5. IIS 10

Attaching the screenshot for reference:

enter image description here

8

Just observed that in Solr 7.1.0 the folder structure is quite different than 6.6.2. Hence the power shell script is unable to find the required folders.

In my case the script is looking for basic_configs folder in \solr-7.1.0\server\solr\configsets, but the folder in no more exists here in Solr 7.1.0, seeme they moved the related files to to \solr-7.1.0\server\solr\configsets_defaults folder.

Hence switching my Solr back to 6.6.2 as that is the recommended version with Sitecore 9. Was giving a try with the latest version of Solr 7.1.0 but seems it is not compatible.

1

Please review your xconnect-solr.json configuration file and make sure you solr configurations are properly set, specially the SorlRoot default value. It should point to the root of your solr installation. Also make sure your BaseConfig configuration Default value is set to "basic_configs" and whether this folder exists within your Solr installation.

Don't know how you have installed Solr but if you are using Bitnami for example it would live in a path like this "Your_Drive:\BitnamiRoot\apache-solr\server\solr\configsets\basic_configs"

hope this helps

  • No Diego that is the problem, on Solr 7.1.0 seems they have changed the folder structure. Thanks for the input though. – Amitabh Vyas Dec 20 '17 at 1:32
0

I have SOLR version 7.3.0 installed.

I ran the 'xconnect-solr.json' script (without any errors) by updating the BaseConfig default value to '_default\conf' as this is where the config files exist in the new folder structure.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.