5

Just set up a new machine, so...

I have a site running locally Sitecore 8.1.160519,

The site has GZip enabled. I see the appropriate header if I just browse to the site. But if I go to the experience editor I get:

This site can’t be reached
The webpage at http://local.mysite.com/?sc_mode=edit&sc_itemid=%7b84981E72-1012-4591-9CCC-89C5A621B0D1%7d&sc_version=1&sc_lang=en&sc_site=mysite might be temporarily down or it may have moved permanently to a new web address.
ERR_CONTENT_DECODING_FAILED

I am sure it is related to GZip because if I turn off GZip, this problem goes away. Also, If I use fiddler and try and look at a request, I get:

The content could not be decompressed.

The magic number in the GZip header is not correct. Make sure you are passing in a GZip stream.

I tried adding my app pool to the IIS temp cache but this seemed to have no effect.

So, somehow IIS is messing up the zipping?

Here is how I have enabled GZip in my web.config:

<system.webServer>
<httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
  <scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" staticCompressionLevel="9" />
  <dynamicTypes>
    <add mimeType="text/*" enabled="true" />
    <add mimeType="message/*" enabled="true" />
    <add mimeType="application/x-javascript" enabled="true" />
    <add mimeType="application/json" enabled="true" />
    <add mimeType="*/*" enabled="false" />
  </dynamicTypes>
  <staticTypes>
    <add mimeType="text/*" enabled="true" />
    <add mimeType="message/*" enabled="true" />
    <add mimeType="application/x-javascript" enabled="true" />
    <add mimeType="application/atom+xml" enabled="true" />
    <add mimeType="application/xaml+xml" enabled="true" />
    <add mimeType="*/*" enabled="false" />
  </staticTypes>
</httpCompression>
<urlCompression doStaticCompression="true" doDynamicCompression="true" dynamicCompressionBeforeCache="true" />

  • Try not to compress dynamic generated items/html <urlCompression doStaticCompression="true" doDynamicCompression="false" dynamicCompressionBeforeCache="true" /> – Abdulrahman Awwad Dec 28 '17 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.