I'm installing Sitecore 9 XP1 Topology, and everything was going well until Content Management step where I received this error

Install-SitecoreConfiguration : Error requesting https://sitecore9-cm/sitecore/admin/PopulateManagedSchema.aspx?indexes=all: The remote server returned an error: (500) Internal Server Error. At line:1 char:1 + Install-SitecoreConfiguration -Path .\sitecore-XP1-cm.json + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

I've found a blog talking about the same error but in his case the log said "Login Failed for user" and mine does not mention anything (at least I didn't find)

When I browse to https://sitecore9-cm I receive the following error

enter image description here

  • 1
    Do you have URL Rewrite 2.1 IIS module installed?
    – Chris Auer
    Commented Jan 6, 2018 at 15:32
  • Just checked and I don't... installing and checking again. Commented Jan 6, 2018 at 15:35
  • @ChrisAuer looks like you were right! URL Rewrite was missing and that was the reason for the error! Commented Jan 6, 2018 at 15:46
  • 1
    Great!. I have seen that error screen many times in my life.
    – Chris Auer
    Commented Jan 6, 2018 at 15:47
  • I am installing it in Windows10 even after all above settings, I am getting the same error. When requesting: sitecore9-cm/sitecore/admin/…: Please let me know if you have any workaround for this. Commented Jul 16, 2018 at 5:15

4 Answers 4


Please make sure you have URL Rewrite IIS module installed? It is a prerequisite for Sitecore 9.

Download the IIS module - https://www.iis.net/downloads/microsoft/url-rewrite


  • Solr 6.6.2 Microsoft
  • PowerShell 5.1 or later (Included in Windows 10)
  • WebAdministration module (Installed when you have configured a computer with IIS)
  • Web Platform Installer 5.0
    • Web Deploy 3.6 for Hosting Servers (Use Web Platform Installer to install)
    • URL Rewrite 2.1 (Use Web Platform Installer to install)
  • Microsoft SQL Server Data-Tier Application Framework (DacFx) version 2016

I had the similar error while installing Sitecore 9 Update 1. I figured out that it is due to missing ASP installation. I installed the ASP .Net 3.5 and 4.7 and gave a try. It worked for me. Please check the below image and give it a try. It might solve the issue for you.

enter image description here


We faced the similar error while installing Sitecore 9 Update 2, because I was configuring on the new machine with first time .Net/Sitecore installation. The problem was due to missing ASP component (ASP, ASP.net 3.5 and ASP.net 4.7) Go to > Control Panel\Programs\Programs and Features Click > Turn Window Features on or off Navigate To > Internet Information Services > World Wide Web Services > Application development features


Asp.net 3.5

Asp.net 4.7

enter image description here

And make sure, all three above option should be checked, if not checked it and click ok. Hope, it will resolve the issue.

  • In our case on fresh win 10 install it has been fixed by installing asp.net using this command: dism /online /enable-feature /all /featurename:IIS-ASPNET45
    – Kamil C
    Commented Jan 29, 2021 at 15:10

This error might be due to your proxy setting. To fix it, follow below steps...

  1. Open Internet Explorer
  2. Go to the Tools menu and click on Internet Options
  3. Select Connection tab
  4. And Click on LAN Settings button
  5. Unchecked on options and check Automatically detect settings option
  6. Click the Ok button and restart your browser

Refer below image for the reference.

enter image description here

Now your xConnect and Sitecore applications should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.