1

I have published to my File system: c:/Sites/intranet-local/Website

I have created a website under Sites in IIS: pointing to the above.

I received the following error:

Cannot read configuration file because it exceeds the maximum file size, thus I set up my Registry to increase the size of MaxWebConfigFileSizeInKB to 400 or Hex 190.

I restarted my site and I am still getting the same error. Is there something else I need to look at.

Note: Sitecore database in NOT local and not installed locally

Sitecore Release 7.2

6

Do you have any additional customization in web.config?

If yes, try breaking your web.config and put your customization in separate patch files.

Meanwhile also have a look at the blog post below, if you are on 64 bit OS then the registry to be edited is different.

https://himadritechblog.wordpress.com/2014/09/27/how-to-fix-cannot-read-configuration-file-because-it-exceeds-the-maximum-file-size/

  • can you reissue the link to blog post – Paul T. Rykiel Jan 9 '18 at 22:21
  • Done, earlier pasted wrong URL mistakenly. – Amitabh Vyas Jan 9 '18 at 22:22
3

The issue is with the web.config being greater than 250KB. You can edit the registry but that is not recommended. The better way to do is to move your Sitecore configuration to patch files in the app_config/include folder.

As Himadri's blog points out you should move the section to a new patch file.

Make sure the patch file is the first one to load because if you have any update/add/delete to properties in Sitecore, they will not be applied. Name the file starting with AAAA or something similar directly in the App_config/include folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.