I am working with the Upgrade to Sitecore 9 in Azure PaaS, however, I also need to switch the Azure Search to Solr that is compatible with the Sirecore 9 PaaS. I have tried looking for any documentations regarding this but haven't found any yet.

It will be of great help, if anybody can suggest some thoughts/documentations on it. Thanks.

  • I you might find this answer helpful sitecore.stackexchange.com/questions/9414/…
    – D0cNet
    Jan 14, 2018 at 4:36
  • @D0cNet what I did is do it in PaaS way. I have already populated the indexes in localhost but the "populate solr managed schema" does not have any indexes. Am i missing something?
    – ZQuiray
    Jan 15, 2018 at 10:33

1 Answer 1


First Verify what cores are available in the Solr app.

Did you go through the process of setting up the cores for Sitecore in the config files?

The "Populate Solr Managed Schema" should contain the cores you have defined for the indexes in Sitecore, then push those cores to the Solr server.

Sitecore documentation here

If all that is good,assuming you have VNets (recommended practice) for both your Web apps,next you'll want to check the communication between the two VNets of the Web Apps,i.e setup VNet peering and allow IP access rules between the Solr VNet and Sitecore VNet.

Azure docs here

-If no VNets are setup then just add the address of your Solr web app to the config file.

Set up the base address for solr in the "Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config" to point to your Solr web app IP.

  • I have made a connection between the Vnets since I can now see the indexes when I browse the [site]/sitecore/admin/showconfig.aspx, but the Rebuild/Populate still not showing indexes.
    – ZQuiray
    Jan 16, 2018 at 4:02
  • There is something is still wrong with the connection to the Solr Server. Check that the ip and port are accessible and open and check the sitecore logs for errors.
    – D0cNet
    Jan 16, 2018 at 4:21
  • Vnet-to-Vnet connection worked! I now have working Solr in Sitecore PaaS. Thanks.
    – ZQuiray
    Jan 19, 2018 at 12:41
  • Cool, would you mind marking this as answered. Thanks
    – D0cNet
    Jan 19, 2018 at 12:52
  • Are you using App Service Environment (ASE) ? There is no support for multi-tenant Azure App Services Web Apps to be deploy inside VNet!?
    – DevUser
    Nov 16, 2018 at 7:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.