I'm attempting to use the 9.0.0 ARM template to deploy a Siteocre 9.0.1 instance. I've hit a bit of a wall with this error:

Package deployment failed
AppGallery Deploy Failed: 'Microsoft.Web.Deployment.DeploymentException: The path '' is not valid for the 'dbFullSql' provider. ---> System.ArgumentNullException: Value cannot be null.
Parameter name: value
    --- End of inner exception stack trace ---
    at Microsoft.Web.Deployment.DeploymentProviderOptions.set_Path(String value)
    at Microsoft.Web.Deployment.ManifestProvider.< GetPostProvidersHelper>d__0.MoveNext()
    at Microsoft.Web.Deployment.WebDeployEventHelper.EventWriteManifest(String sessionId, DeploymentObjectProvider provider)
    at Microsoft.Web.Deployment.DeploymentObject.SyncToInternal(DeploymentObject destObject, DeploymentSyncOptions syncOptions, PayloadTable payloadTable, ContentRootTable contentRootTable, Nullable`1 syncPassId, String syncSessionId)
    at Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentProviderOptions providerOptions, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncOptions)
    at Microsoft.Web.Deployment.WebApi.AppGalleryPackage.Deploy(String deploymentSite, String siteSlotId, Boolean doNotDelete)
    at Microsoft.Web.Deployment.WebApi.DeploymentController.< DownloadAndDeployPackage>d__17.MoveNext()'

I compared the parameters.xml file in the 9.0.0 cloud scwdp against the parameters.xml file in the 9.0.1 scwdp. What I suspect is going on is that there's a casing issue. In the 9.0.0 one, it's dbfullsql but in the 9.0.1 it's dbFullSql. However, I can't figure out where it's defined in the first place to know for certain.

3 Answers 3


FYI, and in case it could help, the new Sitecore ARM Templates just had been released here: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates with this commit "Support for Sitecore 9.0 Update-1": https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/commit/d258f794489abc3e56c67f27af708b519cc157d3


I ran into this today, too. It's because there aren't any values being passed to the web deploy package for the EXM database values. EXM has been added to 9.0.1 but wasn't part of 9.0.0. I ended up adding these values into the cm web app MSDeploy setParmeters in the application.json file:

      "EXM Master DB User Name": "[parameters('exmSqlDatabaseUserName')]",
      "EXM Master DB Password": "[parameters('exmSqlDatabasePassword')]",
      "EXM Master Admin Connection String": "[concat('Encrypt=True;TrustServerCertificate=False;Data Source=', variables('sqlServerFqdnTidy'), ',1433;Initial Catalog=',variables('exmSqlDatabaseNameTidy'),';User Id=', parameters('sqlServerLogin'), ';Password=', parameters('sqlServerPassword'), ';')]",
      "EXM Master Connection String": "[concat('Encrypt=True;TrustServerCertificate=False;Data Source=', variables('sqlServerFqdnTidy'), ',1433;Initial Catalog=',variables('exmSqlDatabaseNameTidy'),';User Id=', parameters('exmSqlDatabaseUserName'), ';Password=', parameters('exmSqlDatabasePassword'), ';')]",          
      "EXM Cryptographic Key": "[parameters('exmCryptoKey')]",
      "EXM Authentication Key": "[parameters('exmAuthKey')]",

I also had to remove the Cloud Search parameters from the reporting and processing MSDeploy steps as they're no longer in the parameters.xml list for those two packages. You'll have to add variables/parameters for the EXM params up the chain in the template as well to pass into these.


The issue i had was that i first tried provisioning 'Sitecore 9.0.1 rev. 171219 (WDP XPSingle packages)'.

I then switched to 'Sitecore 9.0.1 rev. 171219 (WDP XMSingle packages)' as i was having issues and wanted to start with a more simple configuration.

I placed the WDP packages for XPSingle in blob storage, i then went to upload the single WDP for XMSingle and found the WDP was named the same.

However when looking more closely at the two WDPs, i found the parameters.xml in the root had slightly different configuration relating to EXM.

So i upload into different folders, switched the WDP URL and everything worked. I hope this helps you or someone else that approached it the same way as me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.