7

The site was recently upgrdaded to 8.1 and although I can access the Desktop, the content editor throws an error when launched.

This is a local instance of Sitecore that uses Coveo. After all the database restoration, getting the project working etc. - I go to open the Content Editor only to get a "Could not retrieve Coveo for Sitecore license" message. The Coveo license is in the same folder as the Sitecore license (which is correct since Sitecore login works just fine). I cannot seem to update the Coveo license via the control panel - there is no option to do so.

In fact, I don't even need Coveo to do the work I am trying to get done, I just want to get into the Content Editor - any suggestions?

  • 1
    If you can give us the versions to and from, it would be very useful. – ASura Oct 7 '16 at 18:27
  • can you tell us the solution if you found one please? sirius_b – ASura Oct 19 '16 at 20:27
5

Since you mentioned upgrading, the way the coveolicense.xml is generated is a bit different in the newer Coveo/Sitecore versions. The new versions authenticate with the cloud in order to get your org and then write both the Coveolicense.xml in the data folder along with Coveo\ConfigurationEncryptionKeys\IndexingEncryptionKeys file.

The newer version no longer uses Datafolder\Coveo\ConfigurationEncryptionKeys\RijndaelEncryptionKeys

3

I disabled the Coveo config files in the Coveo folder in App_Config\Includes, by appending .example to the end of each of them. I restarted the website and was able to access the content editor just fine.

I may have been able to download and install the Coveo Sitecore package, but I have not tried that. Will update this if I do.

1

Did you install the coveo for sitecore package? I have seen this with other developers where the coveo files were referenced on the solution but the sitecore package was not installed on their local builds. Installing it solved the issue

  • good point - this is necessary to make sure all the items and files are in place. – ASura Oct 7 '16 at 18:46
0

Can you navigate to control panel and see if the Coveo section is populated and run the diagnostic. See what component is complaning and may be you will need to relink the coveo admin credentials and validate license.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.