1

I recently upgraded from 8.2u4 to 8.2u6 and SXA 1.4 to SXA 1.6 and ran into some issues found here. SXA 1.6 Creative Exchange Import Export options grayed out. After resolving this issue, I thought all was good. Until I needed to import and received the following error.

"No locator provider is configured at Sitecore.XA.Foundation.IoC.ServiceLocator.get_Current()..."

Screenshot is attached for the reference.

enter image description here

The issue has been resolved but I thought I would post the answer in case someone else runs into the issue.

2

There is a patch that is under \App_Config\Include\zzz\Sitecore.Support.9318.config that is causing the issue. Once the patch is removed the Import works correctly. There is also an assembly file in the bin folder that needs to be removed.

<assembly name="Sitecore.Support.9318.dll">
    <fileVersion>1.4.0.0</fileVersion>
    <productVersion>1.4.0.0-8.2.4</productVersion>
    <lastWriteTime>11/07/2017 09:23:00</lastWriteTime>
    <md5>67FC4466CE890D60344842D437698089</md5>
  </assembly>

enter image description here

Apparently, the patch has been incorporated into 1.6 and is no longer needed.

I hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.