11

I tried to create a connection for Sitecore 9 instance in Sitecore Explorer.

My steps:

  • Right click on "Connections" in Sitecore Explorer and press "New Connection"
  • Fill necessary fields and press Test button

enter image description here

  • I've got a window with below message. Press "Yes".

enter image description here


  • I've chosen "Update All" and then press "Ok". enter image description here

  • In browse window I've chosen folder with Sitecore 9 instance and press "Ok". In previous version of Sitecore there was folder Website for it, but in Sitecore 9 there is not anymore that folder. enter image description here

  • Result - I've got a message - "Got a No Service error". enter image description here

Can everyone explain how I can create connection? Thanks!

  • I have same problem. Did you have any solution? – Shruthika Katakam Feb 19 '18 at 21:46
  • <location path="sitecore/shell"> <system.web> <authorization> <deny users="?"/> <allow users="*"/> </authorization> </system.web> </location> Just remove deny users line <system.web>, this will remove the permission issue to your local. – Ksigdel Jun 11 '18 at 19:23
20

It's a permission issue that started on Sitecore 9. You have to add this section to your Web.config.

<location path="sitecore/shell/WebService">
    <system.web>
        <authorization>
            <allow users="?,*" />
        </authorization>
    </system.web>
</location>

Please, read this blog post from Rob Ahnemann to learn more.

  • Thanks for answer! I added this section to web.config, but got the same result – Дмитрий Jan 24 '18 at 9:03
  • I would suggest you checking small things such as 1. Are you running Visual Studio as Administrator? 2. You're trying to connect to the hostname "events.tac.local" in the directory "tac.corporate.local". Does your IIS Site point to the same directory and hostname? 3. Is your Sitecore Rocks up to date? 4. Is your Sitecore 9 instance at least working? 5. Does the APP Pool Identity have permission to your Sitecore 9 webfolder? – João Neto Jan 24 '18 at 9:40
  • 1
    You're trying to connect to the hostname "events.tac.local" in the directory "tac.corporate.local". - yep, I fix hostname to "tac.corporate.local". Sitecore 9 instance is working. But connection is still not working( – Дмитрий Jan 24 '18 at 14:04
2

One of my colleagues helped to find a solution! Press right button of the mouse on connection -> Connections -> Edit connection properties and then uncheck "UseDefaultWebProxy". In some reason it was set by default.


UPD When you uncheck "UseDefaultWebProxy" you can have another bug - exception when you try to delete some item (template). To fix this use this artifact - https://ci.appveyor.com/project/JakobChristensen/sitecore-rocks/build/artifacts and then set "UseDefaultWebProxy" to check position.

2

This should no longer be an issue as of Sitecore Rocks 2.1.126, which is now available on the Visual Studio Marketplace, if you install the latest Hard Rocks service. It now includes a local Web.config which will do the necessary security configuration for both the Hard Rocks and Good Old web services.

If you need to use the Good Old service for some reason, you do still need to provide your own authorization override, as described in other answers and this Sitecore KB article.

If you wish to use Rocks with a remote system, the Rocks GitHub releases now include an Update Package as well with the latest Hard Rocks service, including the authorization override. Note that this is not recommended for production use.

1
<location path="sitecore/shell/WebService">
    <system.web>
        <authorization>
            <allow users="?,*" />
        </authorization>
    </system.web>
</location>

this should be added to

C:\inetpub\wwwroot\tac.corporate\Web.config

Not on the Visual Studio editor after doing

Add > Existing item... > Add C:\inetpub\wwwroot\tac.corporate\Web.config

I added it after

 </system.webServer>

Also, make sure that you are on Visual Studio on Administrator.

Now, you can do Add > Existing item... > Add C:\inetpub\wwwroot\tac.corporate\Web.config. (as per the Sitecore Platform Essentials for Developer eLearning Student Lab Guide)

0

The site needs to be active on port 80. Default Sitecore installation, installs on port 443 with SSL. Hard Rock Web service looks for site on port 80. You can do this in IIS -> Website Bindings -> Add

This one resolved the issue, after implementing all the above settings.

0

My sitecore instance had redirects to https and allowed https only. Change your Host Name to https://events.tac.local:433

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.