4

I noticed slight differences in the Solr version for Sitecore 9 update 1. Here 6.6.1 is mentioned whereas the installation guide has 6.6.2. Does the initial 9 release need 6.6.1 and update 1 requires 6.6.2?

7

Do not use SOLR 6.6.1 due to a Solr Bug that has been identified.

Use SOLR 6.6.2, which is the recommended version. The KB article has not been updated to reflect this except in footnote:

Solr server can try to initialize a Solr core twice, resulting in the following error:

> org.apache.solr.common.SolrException: Unable to create core
> [core_name] ... Caused by:
> org.apache.lucene.store.LockObtainFailedException: Lock held by this
> virtual machine:
> C:\solr-6.6.1\server\solr\core_name\data\index\write.lock The error is
> caused by a Solr bug: SOLR-11297

The issue does not affect Sitecore functionality and can be ignored. To resolve the issue, upgrade Solr to 6.6.2.

| improve this answer | |
  • Is there anything written in the Sitecore specs about getting the recommended Solr version to a non dead version or LTS version? – Bakudan Sep 5 '19 at 11:40
  • Nothing written in docs. Lots of folks have had no problem using the LTS version. – Pete Navarra Sep 5 '19 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.