0

I have downloaded Sitecore 9 on premises package and following the guide for Sitecore installation. When I try to install, it gives out the following error every time

enter image description here

It gives out an error for parameter cannot be found that matches parameter name 'SqlServer'. Whereas in the xconnect-xp0.json file, there is a parameter defined "SqlSever".

I have not made any change to the configuration files downloaded though the developer portal for Sitecore.

My machine configurations are following

Windows 10 Powershell 5.1 Solr 6.2.2 Sitecore 9.0.0 rev. 171002 SQL Server 2014

  • Closing this one and pointing it to the new question raised which has a searchable stack trace. This post has pretty poor SEO. – Mark Cassidy Jun 11 '18 at 7:38
1

You are trying to install XP0 instance.

In the installation guide you have "Database Requirements" where it say Sql Server 2014 is not supported for XP instances, it support just XM instances.

enter image description here

You need to install Sql Server SP1 instance.

|improve this answer|||||
1

Tucked towards the bottom of your error it says there is an unrecognised escape sequence in your json file. This means the contents have not been parsed and mapped into the SIF engine for processing, this causes the chain of errors you are seeing.

If you haven't made changes to the json file in question (xconnect-xp0 by the looks of things), please contact support.

Edit: on a second look, that doesn't seem to be the whole error message (there's a trailing '}') on the first line of your screenshot. Was there a json parsing error above too? The SIF engine can't do anything if there's no valid Json passed in.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.