0

I am trying to inspect a package created by the package designer. I extract the zip file into my temp folder ok, but when I open that extracted folder and try to extract the inner package.zip package, I keep getting the Windows error

Windows cannot open the folder.

The Compressed (zipped) Folder 'C:\Temp\xxxxxxxx\package.zip' is invalid.

I have tried re-downloading the package from Sitecore, but I get the same error.

enter image description here

6
  • 1
    Which software you are using to unzip file? Many a time I faced such issue with Winzip. So i always use WinRar and it works fine. Feb 5, 2018 at 10:30
  • @aruntiwari I'm using the built-in functionality in Windows 10. Feb 5, 2018 at 10:32
  • 1
    Had similar issue and 7zip helped me with it. It's fast and it's free
    – Marek Musielak
    Feb 5, 2018 at 10:48
  • Is it a large package? I've no problem on Windows 10 browsing the packages created with Sitecore using the built in functionality. Might be worth trying different software I use 7-zip.org Feb 5, 2018 at 10:49
  • @WesleyLomax no, not a particularly big package - only 2 MB! Not had a problem doing this until today. I will try 7zip. Feb 5, 2018 at 10:56

2 Answers 2

1

In truth, I don't know why Windows 10 can unzip some Sitecore packages, but not others. For the ones that don't work in Windows, 7-Zip seems work fine.

Another thing I have found is that some packages can contain very deeply nested folder structures with file paths over the Windows limit (260 characters). In cases where the package contains file paths close to the windows limit, extracting the package to a less deep folder on your computer can help e.g. C:\temp.

3
  • For Windows 10, you can actually work around this archaeological relic. howtogeek.com/266621/…
    – Mark Cassidy
    Feb 9, 2018 at 0:48
  • @MarkCassidy is the original error I saw related to path lengths then, do you think? Feb 12, 2018 at 12:02
  • 1
    Not entirely sure. Normally I would think your AppPool lacks necessary access to the temp folder, but then all your packages would fail - not just some. I think 7-Zip works using TEMP as a temporary folder while uncompressing; Windows built-in uses something in your AppData (so something like \windows\users\mdresser\appdata - which makes for a much longer path length.
    – Mark Cassidy
    Feb 12, 2018 at 12:13
0

If running to the issue with Windows 10. Try the tar command in PowerShell (for instance) with

tar -xzvf .\package.zip

This will bypass the file name length restrictions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.