2

I have Sitecore Version 8.2 .After the plain installation Experience Analytics,FEM , Experience Profile are seen initially at the launch pad of the Sitecore. But after installing the Projects into Sitecore those features are missing. I checked the License file of the Sitecore.

`Sitecore.Xdb.Base` has a validity till Aug 2018.

The below is the screenshot of latest Sitecore Launchpad

Sitecore Launchpad With Missing Analytics

The Sitecore.XDb.config configuration file is as follows

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <settings>
      <!--  XDB ENABLED
            Determines whether xDB is enabled or not.
            Default value: true
      -->
      <setting name="Xdb.Enabled" value="true" />

      <!--  XDB DISABLED PAGE HANDLER
            The URL of the page that is displayed when the Xdb is disabled. 
            All applications that depend on the Xdb must redirect to this page when Xdb is disabled.
      -->
      <setting name="XdbDisabledUrl" value="/sitecore/service/xdb/disabled.aspx"/>

      <!--  XDB TRACKING ENABLED
            Determines whether tracking is enabled or not.
            Default value: true
      -->
      <setting name="Xdb.Tracking.Enabled" value="true" />

      <!--  XDB TRACKING - KEY BEHAVIOR CACHE - MAXIMUMCACHEENTRYCOUNT
            Specifies the maximum number of items that you can store in the cache for a given category (goals, page events, etc.).
            Default: 50
      -->
      <setting name="Xdb.Tracking.KeyBehaviorCache.MaximumCacheEntryCount" value="50" />

      <!--  XDB TRACKING - KEY BEHAVIOR CACHE - MAXIMUMINTERACTIONOPERIOD
            Specifies the maximum time period (compared against start date time) for interactions that can be included in cache rebuilds or updates.
            Default: 30 days
      -->
      <setting name="Xdb.Tracking.KeyBehaviorCache.MaximumInteractionPeriod" value="30.00:00:00" />

      <!--  XDB TRACKING - KEY BEHAVIOR CACHE - MAXIMUMINTERACTIONCOUNT
            Specifies the maximum number of interactions that can be included in cache rebuilds or updates
            Default: 25
      -->
      <setting name="Xdb.Tracking.KeyBehaviorCache.MaximumInteractionCount" value="25" />
    </settings>

    <pipelines>
      <initialize>
        <processor type="Sitecore.Analytics.Pipelines.Initialize.ShowXdbInfo, Sitecore.Analytics" patch:after="processor[@type='Sitecore.Pipelines.Loader.ShowVersion, Sitecore.Kernel']"/>
      </initialize>
    </pipelines>
  </sitecore>
</configuration>
  • 1
    Are you logged in as Administrator? – Marek Musielak Feb 5 '18 at 10:49
  • yes, there is only one user , sitecore\admin – rams Feb 5 '18 at 10:50
  • 3
    Seeing as it's after deployment of your solution, it implies that you have a custom patch file somewhere disabling xDB. Can you verify using /sitecore/admin/showconfig.aspx ? – Steve McGill Feb 5 '18 at 11:33
  • @SteveMcGill Thanks.Yeah you are right.One of the config, files from the project is overwriting the xdb.enabled from true to false.I have updated the same to true and now it is working – rams Feb 5 '18 at 11:58
4

I had the same issue previously. Please check through the showconfig.aspx page which merge all the sitecore config files to one, to see if there are any other configs which have overwritten the default sitecore setting for the Sitecore Analytics.

  • Yeah I did that and solved the issue raised., Thanks for answering. – rams Feb 5 '18 at 12:32
2

It seems your Analytics is disabled.

Inside Website\App_Config\Include folder, open Sitecore.Xdb.config file and set as true as shown below:

<setting name="Xdb.Enabled" value="true" />

and also make below changes

<setting name="Xdb.Tracking.Enabled" value="true" />
  • Thanks for the reply.the solution given is already present in the file.I have update the question with more details – rams Feb 5 '18 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.