1

I'm using Sitecore 9.01 and I have a few templates which have an Image field. I've noticed that if I click on "Browse" and bring up the Select Media dialog, the Upload media button does not work the way I would expect.

  1. If there is already an image selected, the default behaviour seems to be to upload a media item as a child of the currently selected item. If you select change destination you can select a parent media folder, but this is not the default.

Can I configure this dialog so that it attempts to upload media to the same source I've configured in my template for that field rather than as a child of the current media item?

  1. I use placeholder images as standard values on item creation that I would then expect the author to replace. This allows my initial page to look "nice" for the author as they start putting in the real content. However, I'm currently storing those placeholder images apart from the source folder for that template field. When Upload Media is used it defaults to the placeholder image as destination.

The question is the same as for question 1. Can I configure it so that Upload Media will select the same destination that I have configured as the source for my template field?

enter image description here

The above image shows how the Upload Media dialog is selecting my existing media item "sample-hero image" from my Placeholder Images location. If I select an image and select "Upload media", that new image will be loaded as a child of "sample-hero image" in the media library.

1

Tested this in 9.0.1 and 8.2 and both are having this behavior. It has something to do with the fo parameter send to the upload dialog but not sure how to manipulate that.

As this seems intentional - which does not mean it's not a bug ;) - best thing to do is to contact Sitecore Support. If this turns out to be a bug, they will be able to give you a patch for it. They should be, as this surely doesn't feel like the right behavior.

  • Thanks for that. I dug a little deeper and found where the fo parameter is being populated in the core db SPEAK configuration. A quick hack is to set the fo parameter the same as the ro parameter and that seems to be working - at least for one aspect of my issue. – caleb72 Feb 7 '18 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.