9

While running SIF to install 9.0.1 the powershell script stops during the Install-SitecoreConfiguration @xconnectParams step which deploys the xConnect instance giving the following exception.

TerminatingError(Start-Service): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Failed to start service 'Sitecore XConnect Search Indexer - sc901.xconnect-IndexWorker (sc901.xconnect-IndexWorker)'."
Install-SitecoreConfiguration : Failed to start service 'Sitecore XConnect Search Indexer - sc901.xconnect-IndexWorker 
(sc901.xconnect-IndexWorker)'.
At C:\Sitecore\901\install.ps1:44 char:1
+ Install-SitecoreConfiguration @xconnectParams -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

Install-SitecoreConfiguration : Failed to start service 'Sitecore XConnect Search Indexer - sc901.xconnect-IndexWorker
    (sc901.xconnect-IndexWorker)'.
    At C:\Sitecore\901\install.ps1:44 char:1
    + Install-SitecoreConfiguration @xconnectParams -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

The problem is the Sitecore XConnect Search Indexer Windows Service cannot be started.

Looking at the Windows EventLogs when trying to start that service it appears an Exception occurs when trying to construct the type LicenseException preventing it from starting.

Service cannot be started. System.Runtime.Serialization.SerializationException: The constructor to deserialize an object of type 'Sitecore.Nexus.Licensing.LicenseException' was not found.
   at System.AppDomain.CreateInstanceAndUnwrap(String assemblyName, String typeName)
   at Sitecore.XConnect.Search.Indexer.IndexerAppDomainHost.CreateAppDomainAndIndexer()
   at Sitecore.XConnect.Search.Indexer.IndexerAppDomainHost.Start()
   at Sitecore.XConnect.Search.Indexer.Service.OnStart(String[] args)
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

This exception prevents the Sitecore 9 install from completing.

11

The source of the issue is actually due to the License as hinted by the entry in the EventLogs.

The Sitecore license being used is fine for our 8.0 implementation and even worked without issue installing 9.0.0. However Sitecore support informed us that the License we are using was outdated, even though still valid.

Contact Sitecore Support and ask them to fetch the latest copy of your licence.xml from their CRM. It'll have additional signatures required by 9.0.1 and above.

Before re-running your install script from the beginning, you must clear down the previous install's progress, not doing so resulted in another exception.

Delete the following for both the Sitecore instance and xConnect instance created;

  • IIS app pools
  • IIS websites
  • Webroot folders
  • Databases

Re-running the script referncing the new Licence will now complete successfully.

| improve this answer | |
  • @Johathan I got same issue. I found below message in logs: Required license is missing: Sitecore.xDB.Base so as per sitecore.stackexchange.com/questions/10212/… I verified the license and found I do have Sitecore.xDB.Premium license already. Do I really need to contact Sitecore support OR there is something else happening in my case – Sukhjeevan Apr 15 '18 at 2:16
3

Also faced with the same issue. Checked xConnect event logs are located in:

C:\inetpub\wwwroot\[your Sitecore xConnect]\App_Data\jobs\continuous\IndexWorker\App_data\Logs\

Observed the licence is missing:

[Error] Exception occurred during instantiating of IndexerHost.
Sitecore.Nexus.Licensing.LicenseException: Required license is missing: Sitecore.xDB.Base

Anyway, validated that licence file contains in:

C:\inetpub\wwwroot\[your Sitecore xConnect]\App_Data\license.xml

and

C:\inetpub\wwwroot\[your Sitecore xConnect]\App_Data\jobs\continuous\IndexWorker\App_data\license.xml

But when I opened those license files, just found out that the "Sitecore.xDB.Base" (make a serch by "Sitecore.xDB.Base" key word) expiration date had been expired:

enter image description here

So, just do not skip "Sitecore.xDB.Base" licence expiration check.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.