Questions tagged [active-directory-module]

For questions related to Sitecore's active directory module, including architecture, configuration, customization, integration, etc.

Filter by
Sorted by
Tagged with
0
votes
0answers
24 views

Most roles from AD Connector don't show in Security Editor

I'm attempting to sort out security permissions in our 8.1u3 installation, but I've run into a curious snag: we use the Active Directory connector to pull in all of the users and security groups from ...
0
votes
0answers
26 views

Issue while updating and removing users

Sitecore version : 9.0.2 We are using AD authentication to authenticate users. When we are creating new users ( AD users), they are getting created without any issue.However after creating the users, ...
0
votes
0answers
10 views

Active Directory Module: email with dash in the user name shows up empty

I'm using Sitecore 8.1 rev3, with the Active Directory Module. We have a user with a dash in his email, like name-name.lastname@domain.com; he shows up correctly in the User Manager, but Context.User....
0
votes
2answers
98 views

Active Directory roles not displaying

A while ago I created some documentation on configuring roles in Sitecore for my team. We're using Sitecore 9.0 with the Active Directory module. I set my documentation aside six or so months ago ...
3
votes
1answer
1k views

Sitecore 9.1 and Active Directory compatibility question

I was looking into installing Sitecore 9.1 and was reviewing the modules compatibility table for XP (https://kb.sitecore.net/articles/541788) and was surprised to see no support for Active Directory ...
3
votes
1answer
85 views

Sitecore Active Directory Module: GetUsers() not returning all user records

Sitecore 8.1 here, I'm currently using the Sitecore AD Module 1.3. When I search through my users from the back-end using the User Manager, I can easily find all the users I want. When I try to ...
4
votes
1answer
191 views

Unable to create Sitecore user for an Active Directory user

we have Sitecore.NET 8.0 (rev. 150812) with Active Directory Module 1.3, it all seems to be working correctly and I checked the documentation for the module and our configuration seems to be working ...
0
votes
1answer
572 views

How to login sitecore User using Active directory credentials [closed]

when the CM link is browsed users should be automatically logged in to the CMS.How do i do this ?which pipeline should i over ride .
0
votes
0answers
426 views

Create mock up Active Directory Domain Service

I am working on Sitecore intranet site using LDAP module to import, authenticate and manage the AD users, roles and profiles inside the Sitecore. My question is that I need mock up Active directory ...
2
votes
1answer
308 views

Provider name cannot be null error using Active Directory

After successfully deploying the AD module in Sitecore, complete with members, roles, and profiles, we have now encountered an issue where Sitecore crashes when adding in a second domain. What is ...
5
votes
1answer
333 views

Log in with Azure Active Directory

Our client needs to pre-authenticate with AD before common Sitecore built-in authentication (they don't need the AD users in Sitecore). We switched on "Log in with Azure Active Directory" at our CM ...
4
votes
1answer
877 views

Sitecore Single Sign On

We have a requirement for using Single Sign On. So, basically, we have an application that is developed in Sitecore. Anyone who logins to our network through windows credentials should be able to ...
0
votes
1answer
285 views

Redirecting to /sitecore/admin/LDAPLogin.aspx and Forcing Login

We are having some issues with Active Directory and redirecting to the /sitecore/admin/LDAPLogin.aspx page. What should be properly setup so users are redirected to this page to login? Also just to ...
3
votes
1answer
823 views

How to properly setup Active Directory authentication using LDAPLogin.aspx?

I've setup the Active Directory module (1.3) and the final step that I can't quite figure out is how to get the ldaplogin.aspx page to work without prompting for credentials. Checklist: Windows ...
5
votes
2answers
1k views

Active Directory and SSO in Sitecore 8.1

We are trying to implement AD and SSO in Sitecore 8.1. There is this specific requirement to not move all the AD users to Sitecore Profiles/DB as the list of AD users are huge. Rather we are planning ...
3
votes
1answer
97 views

Default language AD users 1.3 - Sitecore 8.2.u2

"The security settings for the current language prevent you from seeing this item" New users from the AD tries to reach the English version of the site, because their Default Content Language is set ...
11
votes
1answer
155 views

Performance Related Issue - Active Directory, Roles Provider, Multiple documents, and 110,000 groups across multiple OUs

I am working on setting up AD Roles provider and I have run into a bit of an issue -- I am hoping it can be worked around with some fancy configuration however at this point I am not sure. ...
7
votes
2answers
1k views

Can I hide disabled users in the User Manager?

We have Sitecore pulling user information out of Active Directory, and since a chunk of these are marked as disabled (University setting, and a chunk of our students get accounts for the time they're ...