Questions tagged [arm-template]

ARM-templates are Azure Resource Management templates that allow user to deploy an application using a declarative template. This tag should be used for all those kind of question in reference with Sitecore.

Filter by
Sorted by
Tagged with
8
votes
2answers
1k views

How to use an ARM Template to deploy WFFM into a staging slot?

I am trying to deploy a WFFM package on top of the already working Sitecore deploy. My Azure Resource Manager template is based on the work of Rob Habraken and on the Sitecore Azure Quickstart ...
5
votes
2answers
1k views

Start-SitecoreAzureDeployment ends with: property 'templateLink' doesn't exist

I'm using PowerShell toolkit for Azure and ARM Templates for XP1. After running deployment command I get following error New-AzureRmResourceGroupDeployment : 10:36:03 - Error: Code=...
3
votes
1answer
73 views

'Aspnetcoreruntime' not found in scaled ARM template

I was trying to install Sitecore 9.2.0 XP Scaled in Azure using ARM template. But I am getting an error named 'AspNetCoreRuntime' not found. { "id": "/subscriptions/72a1bd21-63be-430d-b8a9-...
3
votes
2answers
84 views

Error: Code=InvalidContentLink when deploying to Azure

I am trying to set-up Sitecore XP 9.2 standalone in Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410 following the link at https://doc.sitecore.com/developers/92/sitecore-experience-manager/...
3
votes
1answer
250 views

Error when deploying Sitecore and SXA module to Azure through Visual Studio Team Services release

We are trying to deploy Sitecore and the SXA module to our Azure Web App through VSTS with ARM templates instead of using the powershell script from the Sitecore Azure Toolkit. The initial Sitecore ...
3
votes
1answer
83 views

HTTP Error 502.5 - Process Failure

I was installed Sitecore XC 9.2.0 Scaled using the ARM template. After successful installation, when I am trying to open theBizFX web app, getting this error. Most probably getting this error ...
2
votes
3answers
37 views

SOLR connection string for ARM template

I am installing Sitecore using the ARM template and using SOLR as a search service. Now I have configured SOLR as master/slave model. While installing Sitecore, which connection string should I ...
2
votes
1answer
16 views

Solr XConnect Search Web Deploy package URL

I am trying to install Sitecore 9.2.0 XP with SOLR in ARM template. For that I need to put the web deploy package of "Solr XConnect Search Web Deploy package URL" in the place of "...
2
votes
1answer
181 views

Switch Azure Search to Solr using ARM Templates

We are using Sitecore 9.0.1 in PAAS and i need to need switch from Azure Search to Solr and i am following this blog http://integryx.net/post/2018/05/05/switch-sitecore-9-from-azure-search-to-solr-...
2
votes
1answer
227 views

Sitecore 9.0.1 Custom ARM template for XP1 with combined roles

I want to create an ARM template to setup 9.0.1 PaaS with the following configuration: 1 appservice with CM, Reporting and Processing 1 appservice with CD xDB fully scaled I'm trying to determine ...
2
votes
1answer
53 views

Entity 'HabitatAuthoring' was not found.“,”CommerceTermKey“:”EntityNotFound"

I have installed Sitecore XC 9.2.0 using the ARM template. When I am trying to access the "BizFX" site, I am getting couple of 400 bad request errors in api/GetNavigationView() & api/...
1
vote
1answer
210 views

Azure PaaS ARM template installation error - “Invalid URI: The URI is empty”

Could anybody please help on below. I'm getting below error after 1 hour of execution in powershell script while installing sitecore on Azure PaaS using ARM template but I can access CM and CD server ...
1
vote
0answers
41 views

Deploy XConnect certificate to ASEv2

Currently I am deploying Sitecore 9 infrastructure at our customer, which hosts web apps at Azure App Service Environments v2 (ASEv2). I am using standard Sitecore ARM templates, with slight ...
1
vote
0answers
95 views

Missing ARM template for Sitecore 9 Update 1 in Azure PaaS [closed]

I see Sitecore 9 Update 1 has been released recently but it is missing in azure ARM templates. Can anybody provide information on it's availability or am i missing something?
0
votes
1answer
49 views

Error: Code=InvalidServiceName | 9.2 PAAS set-up

I am trying to install Sitecore 9.2 Standalone on Azure PAAS using Sitecore Azure Toolkit 2.3.0 rev. 190410. I am following the steps provided at https://doc.sitecore.com/developers/92/sitecore-...