Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
2 votes
1 answer
18 views

PowerShell Remoting not working with an Azure VM

I'm trying to connect to a VM hosted in Azure and for some reason the remoting connection never established like you would typically see while on a corporate network. Things I've checked: Enabled PS ...
user avatar
  • 16.4k
0 votes
2 answers
53 views

Webp Image not generating when azure CDN enabled

With Dianoga.WebP.config enabled, I replaced JSS media handler in web.config: with custom one: using MediaRequestHandler = Sitecore.JavaScriptServices.Media.MediaRequestHandler; public class ...
user avatar
0 votes
0 answers
40 views

Reset Admin password in Sitecore 10.2 using SQL in Azure CM instance

I am working on the Sitecore 10.2 version and the solution is deployed on Azure PAAS, Now I trying to reset the admin password to log in on the CM instance. I have gone through with the below question ...
user avatar
0 votes
0 answers
32 views

OAuth2.0 Federated authentication with Sitecore 9.3

We are upgrading our existing site from Sitecore 8.2 to Sitecore 9.3. We are using federated authentication for our CD site with OAuth2.0. The login to the site is working as expected but in the ...
user avatar
0 votes
2 answers
76 views

Is there a way to access Azure keyvault secrets from sitecore site

I have some secrets stored in azure keyvault. Using the following code, I was able to get the secret values via a console application. using System.Management.Automation; Collection<PSObject> ...
user avatar
  • 317
0 votes
2 answers
38 views

Provision new Azure PaaS staging environment as a copy of Production

Our current production environment is XP 9.1.1 scaled on Azure App Services PaaS. We need to quickly provision a new staging environment as an exact replica of current production one. As you are aware,...
user avatar
  • 33
0 votes
0 answers
27 views

sitecore managed cloud HttpRequstBegin patch config

I have a patch config for HttpRequstBegin... On my local dev it is working as expected. When deployed to sitecore managed cloud it's not getting added before "Sitecore.Pipelines.HttpRequest....
user avatar
0 votes
0 answers
23 views

Static ile like Base theme js and css files returning with HTTP error code 403 - forbidden

We have enabled optimizations for JS and CSS files and the optimized files come from azure CDN but we are getting 403 requests for base theme files in Application Insights. GET /-/media/Base-Themes/...
user avatar
1 vote
0 answers
125 views

Hard Time Creating mssql-init image with Multiple Modules on XP1

I'm trying to create an mssql-init image for XP1 that will install the following components: SPE module CH connector SXA module Coveo Coveo SXA I'll be using this to deploy to an Azure SQL server. I ...
user avatar
0 votes
1 answer
46 views

Unable to find any CM login information in Sitecore 10.1

I cannot find any login messages in my Azure application insights. Only found a logout message like this: AUDIT (sitecore\foo.bar): Logout: sitecore\foo.bar. Does anyone know where to find the login ...
user avatar
1 vote
1 answer
48 views

Sitecore Scheduled task runs on startup

I'm using Sitecore 9.3, I have a custom scheduled task for rebuilding the Sitecore search index at night. My project is hosted on Azure environment, I noticed that if I restart the CM app service then ...
user avatar
0 votes
0 answers
32 views

running unit tests in azure build pipeline for a helix project

We are trying to update our Azure build pipeline to run our Unit tests for our SC 8.2 instance. Our project is structured using helix and our build / publish is done using Gulp. It looks to me like ...
user avatar
1 vote
1 answer
150 views

Not Able to Sync Azure Key Vault Secrets Into Sitecore Pods

I'm following this Microsoft document to integrate AKS with KeyVault: https://docs.microsoft.com/en-us/azure/aks/csi-secrets-store-driver I'm using Sitecore 10.1.0 that uses AKS, my idea is to sync ...
user avatar
0 votes
0 answers
119 views

Login failure for collection user after migrating to Azure SQL

"login failed for collectionuser" errors appear after migrating our Sitecore 10.1.1 databases from self-hosted SQL Server on VM to Azure SQL Database. The site itself is working, but ...
user avatar
0 votes
0 answers
13 views

BlobProviderException - Can't publish media items from Master to Web database [duplicate]

When I am publishing many media items from the master to the web database, it crashes at some point in the process with the following exception: Job started: Publish to 'web'|#Exception: System....
user avatar
1 vote
1 answer
54 views

Sitecore SQL Migration to Azure is Blocked

We have an on premises instance of Sitecore 10.1.1 and want to move the databases from SQL Server on VM to Azure SQL Database. We are leaving the Sitecore sites on VM for now. A migration blocker in ...
user avatar
2 votes
1 answer
212 views

Application Insights on Sitecore 10.1 not logging custom errros from the application

I tried to install Application Insights on Sitecore 10.1 project in Azure PaaS. After installing the AI SDK and configuring the instrumentation key the app insights started to pick up Sitecore logs e....
user avatar
  • 77
0 votes
2 answers
464 views

Upgrade Sitecore 9.1 to Version 10.1.1

We have Sitecore 9.1.1 currently deployed on production environment. Our topology is scaled on Azure App services. It's required to upgrade current version (9.1.1) to the latest Sitecore version (10.1....
user avatar
  • 33
0 votes
1 answer
62 views

Resolve Sitecore.XConnect.Operations.FacetOperationException - should CDs share common redis cache?

The logs of my site are getting full with Sitecore.XConnect.Operations.FacetOperationException. The site uses Sitecore 9.2 in a load-balanced setup on azure with CD1 in UK South and CD2 in UK West ...
user avatar
1 vote
1 answer
99 views

Solr suspicious behavior

I've Sitecore instance hosted on Azure according to below breakdown : Sitecore 9.1 (each component as standalone App Service) Solr 7.2.1 (standalone App Service) App insights configured and connected ...
user avatar
  • 33
0 votes
1 answer
836 views

AzureRM.Profile already loaded when deploying to Azure

I am trying to deploy vanila sitecore 9.1.1 (XM single) to Azure Paas. For this I am using Sitecore Azure Toolkit and Sitecore ARM templates. Below is the Powershell script I am using. $SCTemplates=&...
user avatar
  • 572
1 vote
0 answers
70 views

Files not found on Azure Paas

We have a solution installed on Azure Paas. In the logs we have next errors: Exception: System.IO.FileNotFoundException Message: Could not find file 'D:\home\site\wwwroot\sitecore\shell\client\...
user avatar
  • 17.7k
0 votes
0 answers
91 views

Upload file more than 200 mb in content hub

I am trying to upload files more than 200 MB in Sitecore Content Hub using Blob Storage URLs. For file size 700 MB it is working fine. But for more than 1 GB files, the Azure Blob SAAS URL is getting ...
user avatar
  • 421
2 votes
1 answer
79 views

How to profile Sitecore startup time in Azure

It is quite easy to profile Sitecore startup time on-premise, e.g. using JetBrains dotTrace. However, I can't find any good tools to do the same with Sitecore in Azure. JetBrains dotTrace simply does ...
user avatar
  • 342
0 votes
0 answers
824 views

Powershell script fail with 'Access to the cloud file is denied' error when trying to install SitecoreAzure.Binder module

PackageManagement\Install-Package : Access to the cloud file is denied At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\2.2.5\PSModule.psm1:9711 char:34 + ... talledPackages = ...
user avatar
  • 1
0 votes
1 answer
124 views

How can I show static page during a deployment to Sitecore Manage Cloud?

We are using Sitecore Managed Cloud and we have just one CD web app. Obviously when we deploy the website goes down and we would like to show a static page to the users during this time. Is there an ...
user avatar
  • 77
0 votes
1 answer
62 views

Using vhost for JSS Multi-site setup on Azure App Service

I have a headless proxy multisite setup locally using JSS. I have two sites, SiteA and SiteB. I'm using vhost in node to serve as a middleware to resolve the hostname. http://expressjs.com/en/...
user avatar
  • 353
0 votes
1 answer
61 views

Sitecore 10.0 use Sitecore Azure Toolkit to add SXA to an existing instance of Sitecore

For Sitecore 10.0 (sitecore hosted) installed on Azure App Services what is the commandlet in Sitecore Azure Toolkit to add SXA the existing instance? I have the file Sitecore Experience Accelerator ...
user avatar
3 votes
1 answer
170 views

How do the xConnect Docker containers correspond to the Azure xConnect app services?

I've tried to find documentation on the various xConnect roles that exist and their names and map them to the names of the xConnect containers in an XP1 container setup and an Azure PaaS configuration,...
user avatar
  • 5,055
2 votes
2 answers
334 views

Does Sitecore 10.0.1 support SAML with Okta?

I am using Sitecore 10.0.1 on the Azure App Services platform. I would like to implement federated authentication using saml. I was only able to find documentation using open id connect. Does ...
user avatar
0 votes
2 answers
194 views

Sitecore CD app service connection string is being ignored

I am trying to setup Sitecore CD to work with Blue/Green deployments. As part of this configuration, I am tying to get our database to stay sticky to the staging and production deployment slots This ...
user avatar
0 votes
0 answers
66 views

Unable to install Mssql init job in azure AKS [duplicate]

I was trying to install sitecore on my azure AKS engine. When I run the mssql-init file the jobs fail to create with the following error: Start publishing dacpacs Sqlcmd: Error: Microsoft ODBC ...
user avatar
1 vote
0 answers
309 views

Sitecore login redirects to website and not Launchpad

We are using azure alias URL "https://abc.com/sitecore/login" to access our prod CM site "https://abc-1001-cm.azurewebsites.net/sitecore/login". Earlier we had Sitecore 9.0.1 ...
user avatar
1 vote
1 answer
361 views

How to setup Application Insights for a Solr service hosted on Azure PaaS

We have an Azure PaaS environment for Sitecore 9.3 and Solr App services created. Is there any way to connect Application Insights for the Solr App service? For CM and CD services we have setup the ...
user avatar
2 votes
2 answers
199 views

JSS: Azure deployment

In our case, both test and prod environments are Azure app services. So currently when we deploy to test: I replace the layoutServiceHost and deployUrl in scjssconfig.json to be the address of QA ...
user avatar
  • 554
0 votes
1 answer
100 views

Sitecore PaaS Web DB spikes

We’ve just migrated from Sitecore 8.2.5 on-prem to 9.3 Azure PaaS. Performance seems ok most of the time, but we’re seeing regular spikes to 100% DTU on the web db. The db is standard S2 50 DTU and we’...
user avatar
3 votes
2 answers
769 views

Hard time installing Sitecore 10 external resources in Kubernetes AKS in Azure

I'm trying to install Sitecore 10 on AKS so I was following the steps in Installation_Guide_for_Production_Deployments_with_Kubernetes_XP10.0.0.pdf Installed azureCli & helm on my local pc az ...
user avatar
1 vote
0 answers
455 views

.aspnet.cookie is not set after Azure AD B2C successful authentication

We have an ASP.NET webforms application with Sitecore 9.0.0 Initial release, and we want to use Azure B2C as an external identity provider for our external users. We created the new authentication ...
user avatar
  • 11
1 vote
1 answer
112 views

I've trying to install Sitecore, getting error: Missing source parameter

I am trying to install Sitecore 9 update 2 on Azure. I am getting this error: Package deployment failed ARM-MSDeploy Deploy Failed: 'Microsoft.Web.Deployment.DeploymentClientServerException: Missing ...
user avatar
  • 11
1 vote
1 answer
100 views

unicorn deployment failure - can't sync when deployed to real environments

I am sure I am missing something simple about using Unicorn in environments above the local dev environments the source folder is correct out of Azure Paas, out on my App Service I am in Sitecore 9.3....
user avatar
4 votes
1 answer
136 views

SQL Replication doesn't clear CD caches on remote target

We have a multi-cd publishing situation I can use some help with. We are in an Azure PAAS situation, with the CM and 1 CD server located in the US. We also have a CD Server and SQL database in China (...
user avatar
0 votes
1 answer
127 views

Does Sitecore Azure paas support sticky session?

I want to enable Sticky session on Azure Pass Sitecore CD instances(multiple app services). Is this possible? If not, what are other options that I have?
user avatar
1 vote
1 answer
419 views

What does "Keyword not supported: 'endpoint'" mean and how does it relate to the "messaging" connectionstring?

I'm encountering the following issue but can't find any documentation to troubleshoot this issue. Any tips? 51324 09:55:20 ERROR Messaging : IMessageBus failed to start 'Sitecore.Marketing.Automation....
user avatar
  • 16.4k
1 vote
1 answer
563 views

IDX10500 error when calling Sitecore with JWT token from Postman after updating identity server certificate

I am using Sitecore 9.1 and have recently updated my .pfx identity server certificates in Azure, due to the old ones expiring. After updating the Sitecore.IdentityServer.Host.xml configuration, the ...
user avatar
  • 11
0 votes
1 answer
69 views

Opening HTML microsite from Sitecore Media Library v9.1.1

Looking for settings to open microsite uploaded to the media library in the browser. In the past, we would take an Adobe Captivate HTML export load it into a folder in the media library, and run the ....
user avatar
1 vote
1 answer
113 views

Sitecore Indexing GetLocalDatasourceDependencies

Sitecore 8.2 update 5 on Azure App Services. Anyone knows what could be the reason <pipelines> <indexing.getDependencies> <processor type="Custom....
user avatar
  • 1,593
2 votes
2 answers
110 views

Outage on your sitecore website during an azure platform upgrade

Our website becomes unresponsive and we get Pingdom alerts whenever there is either an azure platform or infrastructure upgrade on our website. This happens once a month. We have an app gateway and ...
user avatar
  • 187
0 votes
2 answers
335 views

Invalid identity provider: sitecoreidentityserver when attempting to login

Attempted to simply login to two different sitecore CM ( test and prod ) Azure PaaS servers and go the following error : Invalid identity provider: sitecoreidentityserver I suspect it has to do with ...
user avatar
0 votes
0 answers
94 views

Problem Installing to Azure China

Sitecore 9.2 I am trying to run an ARM Template to install Sitecore to Azure China. I set the location parameter to "China East 2". When I run Start-SitecoreAzureDeployment, it creates the ...
user avatar
0 votes
0 answers
502 views

"XdbContextLoggingPlugin" XdbContext Batch Execution Exception

I am getting an SQL exception in the XConnect application. Error: ["XdbContextLoggingPlugin"] XdbContext Batch Execution Exception XdbContextLoggingPlugin MessageTemplate: [{0}] XdbContext ...
user avatar
  • 421

1
2 3 4 5
7