Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [azure]

Microsoft Azure is a cloud computing service created by Microsoft for building, testing, deploying, and managing applications and services through a global network of Microsoft-managed data centers. Use this tag for all the Microsoft Azure related questions.

Filter by
Sorted by
Tagged with
1
vote
2answers
26 views

Azure Deploy of CM + Reporting

I'd like to build a deployment of CM and Reporting in a single App Service. Is the best approach to take the XP0 files and try to remove what isn't needed ? Or try and combine The CM and Reporting ...
1
vote
1answer
37 views

Location of Redis cache connection String in XC 9.2.0 PaaS Scaled

I have installed Sitecore 9.2.0 XC Scaled in Azure PasS. Hence there are two Redis cache has been created in azure portal, one for XC and one for XP. I was able to find out where the Redis cache ...
5
votes
0answers
44 views

Log stream on Azure Paas

I have an environment running Sitecore 9.2 on Azure PAAS. It's an upgraded codebase (from 9.0.2) but on a clean setup. I had an issue with logging. Application Insights is working fine - I can see my ...
3
votes
1answer
53 views

HTTP Error 502.5 - Process Failure

I was installed Sitecore XC 9.2.0 Scaled using the ARM template. After successful installation, when I am trying to open theBizFX web app, getting this error. Most probably getting this error ...
0
votes
2answers
40 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
2
votes
2answers
48 views

CORS Error while downloading the fonts from the Azure CDN using Sitecore PaaS

We have configured the Azure CDN for Sitecore Web Apps website, everything is working fine except the Fonts rendering from CDN, and we are getting below error: Any suggestion?
3
votes
1answer
64 views

'Aspnetcoreruntime' not found in scaled ARM template

I was trying to install Sitecore 9.2.0 XP Scaled in Azure using ARM template. But I am getting an error named 'AspNetCoreRuntime' not found. { "id": "/subscriptions/72a1bd21-63be-430d-b8a9-...
0
votes
1answer
47 views

Multi-Site Domain is not resolving Using Azure WAF

I am facing domain resolving issue in Sitecore Multi-Site Solution using Azure PaaS with Azure WAF setup, however, it's working fine if I add the custom domain on Content delivery(Web Apps) level. ...
2
votes
1answer
63 views

Sitecore 9.1 Azure AD infinite redirect on /admin

I have an XP Single instance deployed to Azure PAAS that has been configured to use Azure AD by following this blog post: https://sitecore.derekc.net/setting-up-azure-active-directory-integration-...
0
votes
2answers
23 views

Base Templates are deployed without any language version

We have very bizare issue with our deployment. Project contains of multiple templates and we recently (couple of months ago) introduced couple of base templates. We have prefixed them with underscore,...
0
votes
1answer
15 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
0
votes
2answers
37 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...
0
votes
1answer
18 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
1
vote
2answers
35 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
0
votes
1answer
55 views

Sitecore Identity Service in the Azure App Service is empty

On the IdentityServer I need to access the Sitecore.IdentityServer.Host.xml file to update the values of AllowedCorsOriginsGroup1 and PasswordRecoveryUrl to be the new DNS for the CM instance. This ...
2
votes
1answer
68 views

Getting IDX20803 when trying to log in via IdentityServer on my CD instance

I have a functioning login flow for my site via IdentityServer. When I test the flow on the CM server (but the frontend site) everything works ok. When I try the same thing on my CD server, I get: ...
0
votes
0answers
36 views

Post Condition failed on Migration between Azure Servers

We are trying to migrate our application from Azure US servers to EU Servers. We just copied all the files of Website folder (or wwwroot folder) from US server to EU server. Our Production CM ...
-1
votes
1answer
50 views

Can we deploy helix structure on azure appservice without using teamcity

My team is deploying Sitecore 9.0.2 application to azure appservice for the first time since we got the project. So while reading the ways to deploy the helix website we found that we will need to ...
2
votes
1answer
30 views

Sitecore Azure SQL DB Advisor recommendation - Drop unused indexes

As part of Sitecore 9.1 Azure hosting setup, I'm seeing few SQL DB Advisor recommendations in Azure to drop unused indexes on certain Sitecore tables that were created by Web deploy packages. Since ...
-2
votes
1answer
70 views

How can I restore my deleted web.config file

I'm using Sitecore 9.1.1 on Azure environment, I'm facing a pretty big problem the Web.config has been replaced and I don't know where can I get the file from? Can someone please give me this file ...
2
votes
1answer
89 views

Azure database refdata high intermittent load

We've been running a SC9.1 solution on PAAS for a while now, but have recently noticed intermittent slow response times, both on the CD and the CM. We've correlated it to high load on the refdata-db: ...
1
vote
1answer
32 views

Does Sitecore provide tool to Migrate Analytics DB to Azure SQL

We are migrating from Sitecore v7.2 to v9.1. We would like to migrate customer xDB data on Azure. Can we automate using xDB Data Migration Tool?
1
vote
1answer
42 views

Why are Sitecore roles not persisting quick enough when using a scaled CD?

User scenario is as follows: Anonymous user navigates to website home page Automatically redirected to /login, which detects user is not authenticated & redirects to ADFS User authenticates on ...
5
votes
0answers
53 views

How to filter application insights logs based on log file type

In a regular Sitecore deployment, the logs are written to files such as Crawling.log.yyyyMMdd.txt Search.log.yyyyMMdd.txt log.yyyyMMdd.txt and Publishing.log.yyyyMMdd.txt. When viewing logs in Azure ...
0
votes
0answers
47 views

How to log requests, fail requests on WAF Azure

I'm working with azure WAF solution. I cannot log the WAF gateway requests that are blocked or not how to do it? I tried to do this: https://docs.microsoft.com/en-us/azure/application-gateway/...
2
votes
1answer
70 views

Installing Packages in Sitecore PaaS/WebApp

Sitecore Support has stated that I can’t install packages like PowerShell Extensions and SXA if my PaaS environment is already deployed. They stated I need to redeploy and add these to the ARM ...
1
vote
1answer
32 views

Programmatically uploaded media files are not showing in CD Server

Sitecore Version : 9.0.2 Environment: Azure PaaS CD If upload any media file manually in Content editor, it uploads the media and the filepath field is empty. In program, I need to upload the media ...
3
votes
1answer
100 views

Checklist for Sitecore Security Hardening using Azure PaaS

I am Using Sitecore version 9 on Azure PaaS, Is there any official Sitecore security hardening guide for Azure PaaS ?, I can see some documentation as below link - https://doc.sitecore.com/...
0
votes
0answers
49 views

NullReferenceException while setting up ApplicationInsights with Sitecore 9.1 PaaS

We are following post below for the steps to configure ApplicationInsights and also have applied the patch as specified in the article. After setting things we are getting a NullReferenceException (...
6
votes
3answers
637 views

502 - Web server received an invalid response while acting as a gateway or proxy server

I've noticed the 502 error after deployment to Azure question, but it appears to be related to a failed deployment and rollback of databases - not what we're seeing here. I am getting the above ...
2
votes
1answer
41 views

No SXA 1.7 ARM Template for Sitecore 9.0.1

I have an existing Sitecore 9.0.1 installation on Azure PaaS. I am looking to install SXA 1.7 on this specific version of Sitecore as Sitecore has outlined this version to be compatible in the SXA 1.7 ...
2
votes
1answer
36 views

Contacts not enrolling in Automation Plan in XP Scaled topology

I am using events to enrol contacts in a Marketing Automation plan, and it works fine in XP Single topology, but in an XP Scaled topology (Azure PaaS) the contacts are not being enrolled. The plan is ...
3
votes
1answer
139 views

Sitecore Identity Server on Azure App Service

I need some help to configure the KeyVault connection string for Azure App Service and Sitecore Identity Service. Sitecore Identity Server is based on aspnet core and the connection string settings ...
2
votes
1answer
124 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
-1
votes
1answer
69 views

Cache cleared message every second in Azure Logs

We are trying to figure our an issue where our LIVE sites are getting down for 10 minutes everyday. While going through the Azure logs I am getting the following Warning: WARN web[standardValues] ...
2
votes
1answer
180 views

Is it possible to add Custom 403 Error page in Azure Web Apps

We have built our Sitecore 9.1 solution in Azure Web Apps. We have added custom 403 and 400 error pages by making use of the Error Manager module from Sitecore https://marketplace.sitecore.net/en/...
1
vote
2answers
54 views

Where do the UpdateInstallationWizard.aspx logs get saved in Azure PaaS?

Sitecore 9.0.2. In my experience, the logs should be saved into the temp folder. Our environment is configured like so: <sc.variable name="tempFolder" value="d:\local\temp"/> I've looked ...
0
votes
0answers
16 views

Sitecore Azure Paas Media files not appearing

I have installed fresh new Sitecore Azure Paas (Sitecore 9 update 2). Created a Sitecore packages from my local to the new instance to migrate all the content, media, system and templates. Everything ...
0
votes
1answer
102 views

How does the gulp build transform Sitecore config files?

I'm migrating Sitecore 9.1.0 to Azure. During the process of build on Azure DevOps, I have a gulp tasks, which builds the solution and transforms the configuration files. On certain configuration ...
1
vote
1answer
57 views

Error when installing WDP in on-premises Sitecore 9.1 XP setup

I followed the steps described in this SSE question/answer to create my WDP. Everything works like a charm when deploying this WDP into a Sitecore Azure Paas instance. However, when I try to install ...
5
votes
1answer
55 views

Error while creating a WDP package using AzureToolkit

I'm trying to create a WDP from an existing Sitecore package but I'm facing the following error even after installing DacFX: Microsoft.Web.Deployment.DeploymentDetailedFatalException: The SQL ...
0
votes
0answers
110 views

How am I supposed to configure an Azure Hosted Agent VS2017 build for 9.1?

I'm trying to deploy my Sitecore 9.1 solution to Azure DevOps. I'm using a Hosted VS2017 Agent pool to do that. When it compiles my *.sln solution, an error shows up, explaining that WebApplication....
9
votes
2answers
188 views

How to convert a Sitecore package into a WDP package?

How can I convert a given Sitecore Package previously created using the Package Designer into a WDP package, so that I can create a script to deploy it on my Azure instances?
2
votes
1answer
100 views

Azure Search Indexes are not being added/populated

I am trying to configure azure search in Sitecore. I followed this article to configure it. But when I try to rebuild the indexes, the number of units processed is empty and the indexes are not ...
2
votes
1answer
107 views

Error when Installing Sitecore 9.1 on Azure PaaS

When trying to install Sitecore 9.1 on Azure PaaS, I face the following error: Add-AzureRMAccount : The term 'Add-AzureRMAccount' is not recognized as the name of a cmdlet, function, script file, or ...
2
votes
0answers
138 views

Sitecore schedule task not running on the XP scaled environment (CM server)

We’ve configured Sitecore schedule task, which runs at every 1 hour. The schedule task is running fine after deployment/web app restart but after sometime it’s not working as expected. We’ve verified ...
3
votes
0answers
109 views

Installation issue on migration 9.1.1

I am trying to migrate a Sitecore 9.0.2 to 9.1.1. Following the upgrade guide https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx, I have to ...
8
votes
1answer
84 views

Customising the Sitecore Azure Marketplace Install

I installed Sitecore 9 on Azure using the Azure Marketplace. This creates a highly souped up instance of Sitecore. Id like to strip things out I don't need, to reduce the cost, but I am not entirely ...
2
votes
1answer
228 views

How to deploy Sitecore to a new deployment slot on an existing environment?

I have DTAP environments up and running for this client I'm working for and want to improve the deployment of releases by reducing the downtime / first loadtime. I have read up on blue/green ...
0
votes
1answer
130 views

ERROR Could not run the 'getMediaStream' pipeline for '/sitecore/media library/Images/test '. Original media data will be used

I’ve extended SqlServerDataProvider to use the azure blob storage account for storing the media library assests. I’ve taken reference from below GitHub project: https://github.com/aweber1/Sitecore....